...then i have to change the place for "assemble modules" :)
Posted on 2003-06-29 22:05:05 by cakmak
Hi cakmak

The assembler.ini files have been changed in RadASM 2.0.2.8. If you manually change the ini file then do the following:

Section

MenuMake=Compile RC,Assemble,Link,Build,Go,Run,Run w/debug,Go All,Assemble Modules

In section add:

MenuMake=1,1,1,1,1,1,1,1,1,0
7=0,0,\OllyDbg\OllyDbg,$.exe
17=0,0,\OllyDbg\OllyDbg,$.exe

For each of the project types add:

MenuMake=1,1,1,1,1,1,1,1,1,0 ;Change to what fits the project type
7=0,0,\OllyDbg\OllyDbg,5
17=0,0,\OllyDbg\OllyDbg,5

Chane \OllyDbg\OllyDbg if you use another debugger.

In section change:
1=&Compile RC,55,M,1
2=&Assemble,31,M,2
3=&Link,91,M,3
4=&Build,103,M,2,3
5=-,0,M,
6=&Go,43,M,2,3,4
7=-,0,M,
8=&Run,67,M,4
9=Run w/&Debug,4,M,7
10=-,0,M,
11=Go &All,79,M,1,2,3,4
12=-,0,M,
13=Assemble &Modules,0,M,6

Also there was a bug in the first upload of RadASM 2.0.2.8 that caused Assemble Modules to not be active.

KetilO
Posted on 2003-06-30 02:03:51 by KetilO
Hi all

My new web site is now up to date at:

http://radasm.visualassembler.com/

Thanks _Shawn for hosting.

There is an upcoming bandwith problem so I might hav to split downloads more so you don't download more than you need.

KetilO
Posted on 2003-06-30 02:12:36 by KetilO
Hi Ketil,

If there are Bandwidth issues you can use the following link to RAHelp.zip for a while until you get them worked out:

http://www.nt.net/donkey/files/RAHelp.zip
Posted on 2003-06-30 02:31:46 by donkey
Hi donkey

Thanks, that will help a lot.

KetilO
Posted on 2003-06-30 03:37:56 by KetilO
Thank You, KetilO.

Regards
Posted on 2003-06-30 21:00:06 by cakmak
Ketilo

I would be glad to give you space on one of our servers for Radasm and assorted files if that would help you.

I could just download the files and then set up links you could use on your page as an alternate site to help resolve your bandwidth issues.

I really like your IDE and would be glad to support it by hosting at least an alternate site to take off some of the load on your site.

My email ishttp://www.asmcommunity.net/board/cryptmail.php?tauntspiders=in.your.face@nomail.for.you&id=a990d0854d16c37aea1d8e08ff3cb08e if you need to communicate with me.

Thanks

John
Posted on 2003-07-01 02:42:35 by cookj
I updated all links in the database to reflect your new site address.
Posted on 2003-07-01 11:45:54 by Hiroshimator
Hi cookj

Thanks,
There is no immediate problem so I will let you know if I need to spread downloads.

KetilO
Posted on 2003-07-01 17:22:16 by KetilO
Hi Hiroshimator

Thanks,

KetilO
Posted on 2003-07-01 17:23:48 by KetilO
Try this,

F4 -> up-down -> AltGr+Home -> F4 -> up-down ; loosing focus.

but,

F4 -> up-down -> AltGr+Home -> AltGr+End -> up-down ; this is ok!


all these means, beside "AltGr+End", using "F4" is problem.

Notice that, if you use "Ctrl+Alt+Home" keys before "F4" you won't catch this. Because it works. But unfortunately you won't test this, i suppose, your keyboard doesn't has "AltGr" key. I hope a known solution is exist.

Regards
Posted on 2003-07-01 23:55:31 by cakmak
Hi cakmak

Thanks for the bug report. I do have AltGr key so it was easy for me to reproduce the bug. I will fix it.

KetilO
Posted on 2003-07-02 01:38:11 by KetilO
Hi Ketil,

RadASM will GPF if you select select collapsed text in an edit window to the top of the window and delete or overwrite the text.

To reproduce the bug:
    [*]Open a project with collapsed procs
    [*]Press ctrl-A or Select a collapsed proc and everything to the top of the edit
    [*]Press Backspace or Delete or type a character
    This is reproducible in Win2K and 98SE. I removed the following AddIns to make sure that it wasn't them and it still GPF'ed:
      [*]Colref.dll
      [*]Version-Inc.dll
      [*]style-manager.dll
      [*]RES2DLG.dll
      [*]NoteTools.dll
      [*]AsmVars.dll
      [*]MakeDef.dll
      [*]Bitmask.dll
      [*]ButtonChanger.dll
      This bug does not show up if a collapsed proc is not in the selected text.
Posted on 2003-07-04 02:07:02 by donkey
Thanks donkey

The bug was in RAEdit and was easy to fix.

KetilO
Posted on 2003-07-04 04:51:37 by KetilO
Hi all

RadASM 2.0.2.9 is uploaded to my website.

Whats new:

2.0.2.9
- Several bugs fixed in RadASM and RAEdit.
- Added NoteTools and HexVU addins.
- Updated BitMask, ButtonChanger and Colref addins.
- Exported more RadASM functions/data/handles to addins.

KetilO
Posted on 2003-07-04 06:35:33 by KetilO
Hi Ketil,

Took me a while to notice this but your splash screen is gone. It appears as a small window at 0,0 screen coords.
Posted on 2003-07-04 14:25:30 by donkey
Hi donkey

Don't know what happend to your splash. I have tested on Win98 and WinXP and it works as it should.

1. Check if Luha.bmp is found in addins folder.
2. Check that RadASM.ini contains the following:


Bmp=$R\AddIns\luha.bmp
nShow=15
1=0,120,$V
2=0,142,Copyright (C) KetilO 2001-2003
3=0,164,ketil.olsen@jm-data.no

The small window is caused by NoteTools. See your thread about this.

KetilO
Posted on 2003-07-04 16:47:00 by KetilO
Well, that's a little strange, my RadASM.ini had the following:


Bmp=$R\AddIns\luha.bmp
nShow=15
1=10,120,$V
2=10,142,Copyright (C) KetilO 2001-2003
3=10,164,ketil.olsen@jm-data.no

But I have never touched this. Changing the 10's to 0's fixed the problem.
Posted on 2003-07-04 16:51:27 by donkey
I agree with Donkey
the HexVU is very nice but , you should add the other options.
like search (hex, ascii etc..) , edit , replace , save and etc..

bye


eko
Posted on 2003-07-05 05:43:06 by eko
Hi donkey & eko

Thanks,
I will probably turn it into an hex edit custom control (RAHexEd?).

In the mean time, here is an update with source.

KetilO
Posted on 2003-07-05 06:32:13 by KetilO