Sorry but the template named "dialogasmain.tpl" have error inside!
This is original handle loop:
.while TRUE
invoke GetMessage,addr msg,NULL,0,0
.BREAK .if !eax
invoke TranslateMessage,addr msg
invoke DispatchMessage,addr msg
.endw

But must be:
.while TRUE
invoke GetMessage,addr msg,NULL,0,0
.BREAK .if !eax
invoke IsDialogMessage,hWnd,addr msg
.if eax==FALSE
invoke TranslateMessage,addr msg
invoke DispatchMessage,addr msg
.endif
.endw
And also no cyrillic support :-(
Thanks for such beautyfull IDE it's more powerfull than DELPHI RAD in my first look...
But will live - will see...
BE HIGH!
Posted on 2003-07-05 10:14:31 by reltserw
Errors? No they are not errors. Anyway if you want to use DialogBox as Main might as well use the following codes?


dlgproc proto :DWORD,:DWORD,:DWORD,:DWORD

start:
invoke DialogBoxParam,400000h,1000,0,offset dlgproc,0
invoke ExitProcess,0

dlgproc proc uses ebx edi esi hdlg:DWORD,msg,wparam,lparam
mov eax,msg
cmp eax,WM_COMMAND
je wmcommand
cmp eax,WM_CLOSE
je wmclose
_ret:
xor eax,eax
ret
wmclose:
invoke EndDialog,hdlg,0
jmp _ret
wmcommand:
jmp _ret
Posted on 2003-07-05 10:46:34 by roticv
Hi reltserw,

To change your templates:
    [*]Create a new project using the template
    [*]Make any changes that you want to that template
    [*]Select Create Template from the project menu
    [*]Save the modified template with the same name as the original
    [*]You now have the template exactly how you want it

    There are cases where you will want to add extra files. For example bitmaps andother support files. Put these in on an individual basis. I have changed a few templates to suit my style, if you want other things in your templates just put them in yourself.
Posted on 2003-07-05 11:55:05 by donkey
i've just understand how it's simple:-)
Posted on 2003-07-05 18:26:10 by reltserw
Hi KetilO,

I have another idea(never ends). Automatically square brackets completion option like Fasmw editor. I liked that very much do you interest?

Regards
Posted on 2003-07-05 21:47:08 by cakmak
Hi KetilO,

is it possible to update the OPTIONS->SET PATHS menu to choose a path
for a debugger / for OllyDbg?

If I there's another way to choose it "automatically" (not editing the
*.ini file), please tell me and sorry: I haven't found it!

Thanks and best regards,

BoostMan.
Posted on 2003-07-06 03:34:03 by BoostMan
Hi cakmak
I guess square brackets is just as difficult on your keyboard as it is on mine. I will have a look at FasmW.

Hi BoostMan
There is currently no other way to set path for debugger than by editing the assembler.ini file.
I will see what I can do.

KetilO
Posted on 2003-07-06 05:50:43 by KetilO
Hi Ketilo,


I will have a look at FasmW.


Dont forget to look at 'Smart tabulation', It's cool if RadAsm had one :cool:
Posted on 2003-07-06 08:59:03 by Bi_Dark
Possible highlighting bug?


Try writing:

Commentaries db 0

I suppose it has something to do with "Comment" being reserved in RadASM.


Anyway....keep up the great work on this fine IDE.

:alright:
Posted on 2003-07-07 20:36:17 by peanut
In MASM.INI's section change:

CmntBlock=comment+,-

to

CmntBlock=comment +,-

Notice the space after comment.
Posted on 2003-07-07 21:01:26 by donkey
Thank you donkey

That was a very complicated fix :grin:
Posted on 2003-07-08 14:01:26 by peanut
Hi all

RadASM 2.0.3.0 is uploaded to my website.

What's new:

2.0.3.0
- Improved huge project support.
- Projects loads faster.
- Projects code properties refreshes faster.
- Multi file select on template creation and add existing files to project.
- Convert tab to space and space to tab now works on whole line, not only on the indent.
- Export ID equ's now supports both ver 1.00 and ver 1.01 dialogs. Also autosaves before exporting.
- Non existing projects on MRU projects list is removed on startup.

KetilO
Posted on 2003-07-18 07:08:55 by KetilO
In the new RadASM splash screen gone.I fixed it by the help of donkey's post.However again I see some rectangle flashing at the up left corner when radasm starts.Is it supposed to happen ?.
Posted on 2003-07-18 09:37:15 by LaptoniC
Hi all

RadASM 2.0.3.0 bug.

RadASM 2.0.3.0 did not work well with PthExpl++.dll addin.
RadASM would not load the whole project if PthExpl++ had written in the middle of section

Everybody that downloaded 2.0.3.0 the last 8 hours should download again.

Also added the latest version of notetools addin.

KetilO
Posted on 2003-07-18 13:23:52 by KetilO
Hi donkey

Keeping track of all your addins is more than I can handle. :grin:
Every week a new one.

Just got reports that the RAHelp.zip on yoyr server is broken. Could you upload again?

KetilO
Posted on 2003-07-18 13:26:36 by KetilO
I couldn't find a problem on my server with RAHelp but I just uploaded a frreshly compressed and tested version of the file. I had a report that the zip was corrupt as well, weird it works here but I may have been just re-downloading the one in my browser cache.

:grin: You should see the addin I'm working on now - it'll probably weigh in at 200+K it's already at 150K and it's only half done, very complicated but it will add a completely new dimension and power to RadASM if I can pull it off. Anyway I said too much, don't want to let the cat out of the bag too early.
Posted on 2003-07-18 13:43:31 by donkey
Hi donkey

Now you made me qurious. I will not be able to sleep tonight, wondering what you are working on. :grin:

BTW. Now the RAHelp.zip is OK.

KetilO
Posted on 2003-07-18 14:07:36 by KetilO
Hi all

New upload of RadASM 2.0.3.0

Following bugs fixed:

- Removing a file from project did not work.
- Adding single existing file to project did not work.
- Adding single file to template creator did not work.
- Improved selection by mouse scrolling in RAEdit.

KetilO
Posted on 2003-07-19 14:44:49 by KetilO
Hi Ketil

I found a little bug.

If the radasm.ini section contains no entry
it crashes RadASM when trying to create a new project.

I tried it with a fresh install of version 2.0.3.0 posted 19/7.
It works if i previously opened an existing project.


Hope you find the cure or can give me some advice.

Edit:

Btw it seems my old install of 2.0.2.9 updated to latest 2.0.3.0
also has this problem. And that radasm.ini HAS entries in the section.

Go figure :confused:
Posted on 2003-07-19 21:36:30 by peanut
Hey KetilO, I am going to second that bug by peanut. I updated to the newest version and when trying to create a new project, RadASM crashes. It does create the folder, and asm file but not the bak/res folder or the inc file.
Posted on 2003-07-19 22:31:41 by Gunner