When I use the "win32inc", it needs me to change the include directory, but I don't know how to. I just changed all the "%include" to "i nclude" and it works--don't laugh at me:) , can you tell me how to use it correctly?
Posted on 2003-01-08 21:35:08 by LiuGuoHua(Chinese)
Posted on 2003-01-09 02:32:40 by Tomasz Grysztar
BTW, since FASMW has been updated, "win32inc" pack is now obsolete.
Posted on 2003-01-09 02:48:32 by Tomasz Grysztar
Thanks for your quick answer , Privalov!
I hope some one can modify the win32inc to make it valible again.
Posted on 2003-01-10 00:05:40 by LiuGuoHua(Chinese)
It's not needed, because FASMW package now contains everything that win32inc contained, and more.
Posted on 2003-01-10 03:13:25 by Tomasz Grysztar
Privalov,
Maybe you can you add support for multiple include path's? because i also have it already defined for masm.
My include variable is now set to: INCLUDE=c:\fasm143\include;c:\masm32\include but fasm will not find the include files this way. Masm does tho.
Posted on 2003-01-10 08:12:07 by savage

Privalov,
Maybe you can you add support for multiple include path's? because i also have it already defined for masm.
My include variable is now set to: INCLUDE=c:\fasm143\include;c:\masm32\include but fasm will not find the include files this way. Masm does tho.


Good idea!
Bad thing is, Linux uses the ' : ' as a delimiter:



bazik@exodus bazik $ echo $PATH
/bin:/usr/bin:/usr/local/bin:/opt/bin:/opt/Acrobat5:/usr/X11R6/bin:/opt/sun-jdk-1.4.1.01/bin:/opt/sun-jdk-1.4.1.01/jre/bin
bazik@exodus bazik $


Would make it a bit more difficult to write a parser ;)
(but you could use a starting slash as indicator for Linux paths)
Posted on 2003-01-10 09:13:58 by bazik
This is not any "search path" setting, fasm just replaces the names of environment variables with their values and that's why it's working this way - it has nothing to do with file searching/opening.
Posted on 2003-01-10 09:55:50 by Tomasz Grysztar

This is not any "search path" setting, fasm just replaces the names of environment variables with their values and that's why it's working this way - it has nothing to do with file searching/opening.


Ah ok :)
Posted on 2003-01-10 10:06:25 by bazik
What about making it possible to set a variable inside FASMW (not an environment variable) that is stored in the INI-file and then use this as a kind of "environment variable" in the include-path... ?
Posted on 2003-01-10 11:23:30 by POW
And that was very easy to do - only few lines of code. FASMW 0.9.56 now searches for variable in the "Environment" section of .INI file, and only when it's not found there, it uses the standard environment variable. I've put the info about this feature in readme.txt.
Posted on 2003-01-10 11:58:46 by Tomasz Grysztar
cool :alright:
Posted on 2003-01-10 13:42:10 by savage
That was fast Privalov! Thanks! :)
Posted on 2003-01-10 14:32:16 by POW