I have problem(s) with sniplet window in RadAsm 2.0
I don't know what is the cause of the problem, of course,
so I'll give all history information about it.
In my RadAsm.ini option Expanded was = 1.
In the Sniplet directory was file DialogProc.asm,
I never used it though I kept it 'cause it was no harm, exept
for one minor thing:
when I called for sniplet window, it always opened with this
file selected (question #1: what can I do so that
sniplet window would opend with selected file of my choise?)
All the time I needed to select other then DialogProc.asm,
more to it that I often needed to copy Dialog sceleton proc from my
DlgProc.asm and when working in speed it is easy to missselect
DialogProc.asm instead of DlgProc.asm 'cause their names and
perpose are simular, I sometime would accidently do it.
Both those things finaly got me complitly annoyed and 'cause I
didn't know how to change what file is selected in the window,
I just deleted the DialogProc.asm.

And here is when new problem started with RadAsm 2.0....
When one file is choosen in the sniplet window and then
another (doesn't matter if text of previous file was selected)
file text of BOTH files appears in the sniplet text window.
By "selected file" I mean that file was selected in tree view component
of the sniplet window.
Still I couldn't get file of my choise to be selected when the window appears,
so I set an option "Extended" to 0.
After I set this option to 1 again, none of the files was selected when
window appears, selection in TreeView was on "Folder Code" icon.

It doesn't happend with RadAsm 1.2....
I mean copying several files texts into text window.
So questions about it is:
1. The bag itself - please, fix this several files inserting into one window.
2. How could I say to RadAsm which file wich file should be selected in TreeView
component
3.minor question: In RadAsm 2.0... text window in "colored" those
in setting in all possible places I remove coloring texts.
How could I get just plain black\white in sniplet window
(in RadAsm 1.2... snipplet text window appears in black\white
in RadAsm 2... - colored I keep both exe of the two version in one
directory so that they share the same configuration files)
Posted on 2003-01-29 08:21:33 by The Svin
Hi The Svin

The only way to avoid first file to be selected is to put all files in sub folders or to give it a name higher than first sub folder. BTW Sub folders is also a great way to group them. If you want a file to be selected, do not put it in a sub folder and give it a name lower than first sub folder.

There was a bug in early 2.0.0.x version that would just add text. You should download 2.0.0.7 as there are several important fixes.

Colors in sniplet window will be the same as in code edit window.

Nothing prevents you from having two different versions sharing same ini files. Just rename one of the exe files.

KetilO
Posted on 2003-01-29 08:51:41 by KetilO
"Colors in sniplet window will be the same as in code edit window"

No, they are not.
Code window doesn't use highlighting at all,
and despite the fact sniplet window colored (uses highlighting).

"The only way to avoid first file to be selected is to put all files
in sub folders or to give it a name higher than first sub folder"
:)
It wasn't the 1st file in my story, and nevertheless it was selected.
It was 4th !
Before it alphabetically were 3 other files.
And nevetheless it was selected each time I opened sniplet.
And it was in subfolder "code".

Yet I loaded 2.0.0.7
Sniplet now works OK.
BTW:
Sometime GPF occurs.
More than others there is such a scenario:

Condition: No output window before I start making.
Then something went wrong (for example I've made some syntax errors
in source)
I open output window. It scrolled so that I can't see out text describing the errors.
I use scroll bar so that I can see upper text in output window,
AND THERE IS WHEN the GPF HAPPENS.

I wrote in the example 2 conditions
(1. Before I start making output window is not present.
2. Error occurs.)
for a reason.
It seems that bug somehow related to auto scrolling.
And when output window is present before filled with making output
text or if text can fit window (no scrolling needed) the bug doesn't occure.
Posted on 2003-01-29 11:42:54 by The Svin
Hi The Svin

This should solve your problems.

KetilO

Edit:
Attachment deleted.
Posted on 2003-01-29 13:13:23 by KetilO
You are fast indeed! :)
Thanx.
Other thing: in Dialog editor try to make static window
with ...111 flags (rectangle frame) and after that move other controls over it.
Posted on 2003-01-29 16:57:44 by The Svin
Hi The Svin

Yes I know.
Use the shape control instead. It is intended for rect, frame and line drawing.

KetilO
Posted on 2003-01-30 01:40:12 by KetilO
Ketil,
In text window combination ctrl+arrow doesn't work
with national characters. Text cursor jmps only one character,
no matter if arrow or ctrl+arrow has been pressed.
It works though with the first half of symbol table.
Posted on 2003-01-30 15:37:16 by The Svin
Hi The Svin

Yes that behaviour is expected since I have only set up half of the character table in RAEdit. I did this in order to not mess with DBCS fonts. I will continue the work on this and see if I can come up with a solution.

KetilO
Posted on 2003-01-31 02:35:54 by KetilO
About Shape control.
If I made some control before shape control, then
when I place it on shape control it is unseen
(under the shape control).
Is it supposed to be such a way?
Please, explain logic, when control can be placed on
shape and when it is covered by it?
Does it relait somehow to controls IDs?
Posted on 2003-01-31 17:37:45 by The Svin
Hi The Svin

The last created will be the topmost control.
Use Format / Send to back or Bring to front to shift the order.

KetilO
Posted on 2003-02-01 02:32:34 by KetilO