ok, check this out. i run this:
--------------------------------------------------------------------
@echo off

echo Assembling dodot Control library.


\masm32\bin\ml /c /coff *.asm

\masm32\bin\lib dodot.obj /out:dodot.lib


copy dodot.lib \masm32\lib\dodot.lib
copy dodot.inc \masm32\include\dodot.inc

echo.
echo two files sould be copied

pause
-----------------------------------------------------------------------
makefile, and each time it gives me a different result. the order seems random sometimes it will work, sometimes not... ...any clues? i feel like i'm playing the pokies each time i want to recompile.
Posted on 2003-02-03 03:09:06 by Crunchi
and this one...
Posted on 2003-02-03 03:10:47 by Crunchi
finally this one...


seen this before?
Posted on 2003-02-03 03:11:33 by Crunchi
oh,.... and sometimes it works perfectly too. but thats the boring case....
Posted on 2003-02-03 03:13:02 by Crunchi
My guess : A sharing violation while trying to copy a file that is loaded with non-shared access.:rolleyes:
Posted on 2003-02-03 03:37:02 by Axial
hmmm.....

this happens because.....

this can be fixed how.....

sorry very stupid here, i use a makefile like this quite often and this doesn't usually happen. i dunno, just wondering if anyones seen this before.
Posted on 2003-02-03 05:48:12 by Crunchi
maybe built in some error checking loops. The problem here is that it seems to rush to different instructions too fast.
Posted on 2003-02-03 06:10:59 by Hiroshimator
>this happens because.....

It is possible that the lib hasn't finished to be built up while you're trying to copy it.

>this can be fixed how.....

Try putting a "pause" between "\masm32\bin\ml /c /coff *.asm
\masm32\bin\lib dodot.obj /out:dodot.lib" and "copy dodot.lib \masm32\lib\dodot.lib
copy dodot.inc \masm32\include\dodot.inc"
Posted on 2003-02-03 06:28:04 by Axial
AHA!

this works fine now. i thought of doing something similar but i thought this was a bandaid type solution so i was over complicating things i guess. thanks for the help.

well, it works. now its time to get the ret of MY bugs out of the code.

sorry if i seemed a bit snappy, 6 hours of cutting back code to find the error is in your makefile will do that to you.

case closed unless someone knows a better way to fix this.



:grin: crunchi
Posted on 2003-02-03 06:51:13 by Crunchi
crunchi, try this:

make an app that sleeps for 1 second and then just exits.

place calls to that app between your calls. maybe the delay is sufficient and the extra 2 seconds will not kill you.

I hope it helps.
Posted on 2003-02-03 07:58:33 by Hiroshimator
i gave this a shot, saves me having to press the "any key" twice and it reminds me what i"m doing.
:grin: ... easier than writing a whole new app too.

----------------------------------------------------------------
@echo off

echo Assembling dodot Control library.


\masm32\bin\ml /c /coff *.asm
echo. waiting...
echo. waiting...
echo. waiting...

\masm32\bin\lib dodot.obj /out:dodot.lib
echo. waiting...
echo. waiting...
echo. waiting...

copy dodot.lib \masm32\lib\dodot.lib
copy dodot.inc \masm32\include\dodot.inc

echo.
echo two files sould be copied

pause

-----------------------------------------------------------------

thanks hiroshimator

Crunchi
Posted on 2003-02-03 17:27:23 by Crunchi
Crunchi, do you have some antivirus program running?
I have Norton Antivirus, and i get these sharing violations with Visual Studio 6. For some reason i can't save any file in the VS, because the Norton is searching it for viruses or something.. I had to turn the antivirus service off.
Posted on 2003-02-06 15:03:57 by Petroizki
i tried what you said, it works more often but maybe 1 in 20 times it still happens, i think norton is definitely involved somewhere, possibly there is another program doing things too?

thanks for the suggestion.
Posted on 2003-02-10 20:29:44 by Crunchi
Did you turn off the service or just the program?
You can find the services in W2k/XP with run command 'services.msc', there you can find the 'Norton Antivirus Auto Protect Service' or similar. There is more information about other windows services in: W2k/XP services (really good site :cool: ).
Posted on 2003-02-11 06:51:24 by Petroizki
maybe the automatic indexing service? You have that on win2K+
Posted on 2003-02-11 19:37:47 by Hiroshimator
tried what you said, still didn't totally fix things but... ...actually got a meaning ful error this time.
said "cannot access this file because it is being used by another process" i think the FBI, CIA, NSA and the PCYC are examining each of my files as they are produced... ...maybe its an anti-terrorism thing.

i don't have the automatic indexing activated. still it's great all the publicity i'm getting on this thing, thanks for the help guys.

crunchi
Posted on 2003-02-11 21:35:45 by Crunchi