I have just had a problem with the search and replace in QE from a Turkish programmer and there are a number of things that I don't have a way to answer what the problem is.

These are the sample texts that he sent me from a before and after a replace.


szText _text, "yaz?"
szText _text, "yazi"

szText _caption, "ba?l?k"
szText _caption, "baslik"

invoke MessageBox, hWnd, ADDR _text, ADDR _caption, MB_OK
invoke MessageBox, hWnd, ADDR _text, ADDR _caption, MB_OK

szText _replace, "replace"
szText _replacedText, "replacedText"


I have scoured the code that does the replacement which I have used for some years and it has always been reliable, even in binary replacement but there may be things about a Turkish version of Windows that I don't understand.

the first problem is what appears to be some remapping of non english characters to english characters, the second problem reported does not show up on my own version of windows.

If anyone has any info on differences with the Turkish version or has had the same problem, would you let me know ?

Regards,

hutch@movsd.com
Posted on 2003-03-27 22:30:32 by hutch--
Hi Hutch,

I use Turkish version Win98 and I see all Turkish characters normal,

No problem :alright:

Regards,
Posted on 2003-03-27 23:43:02 by CYDONIA
Hi Hutch,

For command line Turkish region adjustments:

Autoexec.bat


mode con codepage prepare=((857) C:\WINDOWS\COMMAND\ega2.cpi)
mode con codepage select=857
keyb tr,,C:\WINDOWS\COMMAND\keybrd2.sys /id:179


Config.sys



device=C:\WINDOWS\COMMAND\display.sys con=(ega,,1)
Country=090,857,C:\WINDOWS\COMMAND\country.sys



Special Turkish characters and reserved ASCII numbers are like below:

Regards,
Posted on 2003-03-27 23:50:07 by CYDONIA
Thats how it looks on a German Win2K...
Posted on 2003-03-28 01:23:25 by bazik
Hi Hutch,how are you?

After reading your post,I tried the find and replace functions of the Quick Editor.

Best Regards,

Vortex
Posted on 2003-03-28 03:10:43 by Vortex
Guys,

Thanks very much for your help here, i will have to try and track it down but I have a slight problem, the power supply on my main development machine just went "BANG" a few hours ago and I cannot get into it at all, probably a new power supply will do the job but a Friday night is not the best time to try and get one.

I may pull the third HDD and try and write it to another box.

Regards,

hutch@movsd.com
Posted on 2003-03-28 05:00:39 by hutch--
hutch, how is the search&replace done? windows function or own code? ansi/mbcs or unicode? I really wish we could drop a lot of language special chars and drop the need for unicode, but I doubt this is ever going to happen (unless bush and friends make more plans :rolleyes: )
Posted on 2003-03-28 05:27:16 by f0dder
f0dder,

Its actually a high level function in PowerBASIC, I have used it for years doing byte level replacement over the full character range in ascii and its been perfect in every instance. What I suspect is that the character set is being remapped prior to it being passed to the function and it may be being done in the dialog edit control.

I have just backup up the actual disk from the box with the blown power supply on my other two machines so i may be able to play with it in a while. Bit of a pain as I had the P4 set up well just for development and now I have it spread back on my internet box and old PIII box.

Regards,

hutch@movsd.com
Posted on 2003-03-28 06:59:06 by hutch--
perhaps it's getting messed up when you get the text from the edit control?
Posted on 2003-03-30 06:50:16 by f0dder
Guys,

I need you to try out something for me in a Turkish edition of Windows. Change the font in QE to a true type font that definitely has the correct set of characters and try out the replacement with these.

I just had this suggestion from a friend in Norway who has seen a similar problem with his own software that does not use English character sets either.

Regards,

hutch@movsd.com
Posted on 2003-03-30 07:05:46 by hutch--
Hutch,

Thanks for the advice.I changed the font to a true type font but
It didn't work.

Best regards,

Vortex
Posted on 2003-03-30 09:05:37 by Vortex
Vortex --

There are reasons to think that you use 2k or XP and default language is English.
Open regional settings in Control Panel.
There are two "Language" fields. The field at the top (Language (location)) is relative to dates and so on.

Another field sounds something like 'System language parameters'. Click the button 'Set default' and verify, which language is default.
If non-Turkish, set to Turkish
Posted on 2003-04-03 13:54:31 by Semion Matusovskiy
Hi Semion,

Welcome to the board! :)

My Win XP's default language is Turkish; so I have no reason to
change any settings.

Regards,

Vortex
Posted on 2003-04-04 00:13:00 by Vortex
Hi Vortex --
At first, it's necessary to be sure that we talk
1) about the same release. My qeditor is dated October 28, 2001
2) case sensitive search
Non-case sensitive search doesn't work for Chr$(128 ... 255), because qeditor uses PowerBasic UCase function instead of API CharUpper.

So ... You wrote that qeditor can't find, for example, small letter g with breve (0?F0).
I reboot to Russian XP, set Turkish as default, and qeditor found this letter w/o problems.

Well ... You wrote that "My Win XP's default language is Turkish".
Which value returns GetACP on your PC ?

BTW, regional settings under XP (unlike, let's say, 2k) have two tabs. First, which you see, when click "regional settings" looks similar 2k.
Guess, you set to Turkish only these parameters. Meanwhile important is located in 'Additional' and sounds something like "Default language for apps, which do not support Unicode".

Added later.
I downloaded the latest masm32 (v8). QEditor is dated Feb, 1, 2002.
If you talk about this release, I am ready to agree - there are problems (with Russian also).
I'll discuss this question with Steven on another (PB) forum.
Posted on 2003-04-04 03:30:47 by Semion Matusovskiy
Hi Semion,

The GetACP function returns 1254(Windows 3.1 Turkish).The settings you have
mentioned are correct on my XP.I am using the latest version of Quick Editor.

Thanks for your interest,

Regards,

Vortex
Posted on 2003-04-05 03:11:40 by Vortex
Vortex,

Thanks for testing the problem on XP for me, I have no way of doing it myself.

Regards,

hutch@movsd.com
Posted on 2003-04-05 04:45:22 by hutch--