To Bi_Dark:

I also have (XP SP1) and I can not duplicate your problem.

Are you using a THAI character set?

Thanks,

Ewayne
Posted on 2003-04-11 09:07:37 by Ewayne
Ewayne,

I have Multilang version and added support both Eng&Thai chaset (Switch to each other with grave '~' key). I switched to Eng when I ran.

I wonder my copy doesn't have export name table, Are you using ordinaly export?

->Export Table
Characteristics: 0x00000000
TimeDateStamp: 0x3E9619A3 (GMT: Fri Apr 11 01:25:55 2003)
MajorVersion: 0x0000
MinorVersion: 0x0000 -> 0.00
Name: 0x0000A878 ("RichEdit44.dll")
Base: 0x00000001
NumberOfFunctions: 0x00000000
NumberOfNames: 0x00000000
AddressOfFunctions: 0x0000A878
AddressOfNames: 0x0000A878
AddressOfNameOrdinals: 0x0000A878

Ordinal RVA Symbol Name
------- ---------- ----------------------------------
Posted on 2003-04-11 21:31:27 by Bi_Dark
To Bi_Dark:

RichEdit44.dll does not have an export table.

I'm attaching a test RichEdit44Test.zip for you to try.

When you execute the program you should see a series
of message boxes with numerical vavues 1111 thru 8888.

Let me know what the last value is and I will go from there.

Thanks,

Ewayne
Posted on 2003-04-11 22:33:18 by Ewayne
Ewayne,

2222 is the last value I can see.
Posted on 2003-04-11 22:42:53 by Bi_Dark
To Bi_Dark:

Another test.

When you execute the program you should see:

1. 1111
2. Some number or 0

3. 2222
4. Some number or 0

The above may repeat two or more times.

Thanks,

Ewayne
Posted on 2003-04-11 23:53:35 by Ewayne
Ewayne,

The value for 1111 is:
Dec. 1111
Hex. 00000457
Bin. 10001010111
---------------------------
Dec. 1
Hex. 00000001
Bin. 1

The value for 2222 is:
Dec. 2222
Hex. 000008AE
Bin. 100010101110
----------------------------
Dec. 0
Hex. 00000000
Bin. <Blank>

I have repeat the process many times and still got the same result, so an error window will popup.
Posted on 2003-04-12 00:02:28 by Bi_Dark
To Bi_Dark:

Thanks, now I know where the problem is.

All I have to do now is fixit and not screw up something else.

When the program is loaded on your machine it is not creating
a fixed width font?

I will get back with you.

Thanks again.

Ewayne
Posted on 2003-04-12 00:10:14 by Ewayne
To Bi_Dark:

See how this one works.

Ewayne
Posted on 2003-04-12 13:50:52 by Ewayne
Ewayne,


Oke Doke:alright:
Posted on 2003-04-12 20:42:23 by Bi_Dark
To TBD:


2. bug? for line with right arrow icon
2.1. line hilite (shift+1,2,3,4)
2.2. scroll using the scroll bar
2.3. hilite disappear
** Fixed **

3. No HighLite use B&W not working.
I can not get it to fail with Win98, NT 4.0, or XP.
What steps are you using?

4. it is possible to collapse procedures ?
I have no immediate plans to do so, if I have enough request
I might try to figure out how to do it.

5. right arrow icon for DispatchMessage (bug or feature) ?
The green right arror icon is just an eye catcher for the start of
a procedure.

You can go to the first post of this thread for the update.

Thanks,

Ewayne
Posted on 2003-04-12 23:06:15 by Ewayne
Ewayne:

> No HighLite use B&W not working.
from the menu i understand if it is selected than the syntax coloring
will be disabled.

my steps:
1. load .asm file
2. select "No HighLite use B&W not working"
3. it looks the same instead of being B&W (a la notepad)

everything else works ok. :alright:
Posted on 2003-04-14 00:15:14 by TBD
To TBD:

Do one more step.

Toggle the HighLite button on the Toolbar (Light bulb).

Thanks,

Ewayne
Posted on 2003-04-14 10:44:03 by Ewayne
Hi Ewayne,

No bugs detected under W2k, Win98 SE and Win NT sp6a.
Nice work

ipadilla
Posted on 2003-04-14 12:54:29 by ipadilla
Ewayne:

aha! it is a bit confusing from the menu. maybe a redesign of the menu ?
suggestion for the menu:
Format/SyntaxColoring/Active
Format/SyntaxColoring/No Color (inactive if SyntaxColoring is Active)

or something like that.
Posted on 2003-04-15 00:49:00 by TBD
To TBD:

I'm glad it works.

RichEdit44Test is just a dump test program, if I ever put the control
in AsmEdit it will be more user friendly.

Thanks,

Ewayne
Posted on 2003-04-15 01:35:19 by Ewayne
Hi Ewayne,

A long time without hearing from you. Have you finished the RichEdit44?
I hope you haven?t any problem.

Regards
ipadilla
Posted on 2003-06-11 13:03:57 by ipadilla
To All;

I didn't disappear, I got volunteered to help my friend build his house and
after working 10 - 12 hours a day 7 days a week all I want to do at night is
sleep. I said after I built my last house that I would not do it again (Getting too old).

I should be done in a couple of weeks.

Thanks,

Ewayne
Posted on 2003-06-11 20:54:56 by Ewayne
Hi,

I'm back, the house is done.

Horizontal mouse select scroll test.

I never liked the way that M$ EDIT and RICHEDIT and a lot of other edit
programs done their horizontal mouse select scroll.

I had some trouble with non fixed width fonts, but I think it came out ok.

The instructions are in the ScrollTest.txt file that you can also use as
a test file.

If you have to adjust the scroll speed let me know what your CPU speed is
and what you adjusted the speed to so I can change my formula.

You can go to the first post of this thread for the update.

Thanks,

Ewayne
Posted on 2003-07-08 16:27:30 by Ewayne
Hi Ewayne,

Glad you're back!

The test works great and as advertised (when you scroll towards the right to begin with...I don't think you have it programmed to start out going left yet since it didn't work that way).

I think I like the ability to change scroll speed and vote to leave it in. The default speed of 035 is fine though and I probably wouldn't normally change it.

You mentioned some problems with non-fixed width fonts so I tried several different fonts with the scrolling and noticed the control acts a little different than with Courier New...such as the inverted line highlighting disappears on the visible screen until you stop and back up a bit (and using some fonts - the entire visible highlighted text also disappears) but when you back up a little, it is properly selected and highlighted.

I am still using WinME on a Compaq AMD 1ghz
Posted on 2003-07-08 19:31:47 by gscundiff
To gscundiff:

The left scrolling loop will only work after scrolling to the right
and then with the left mouse button still down move the cursor
to the left and when the cursor is within 100 pixels of the left
edge of the edit window it will go into a left scroll loop.

You were probably scrolling the window with the scrollbar and
then scrolling left with the mouse button.

I saw no need to do a left scroll loop when you start out with
a backward selection, but I could put it in.

The problem I had with the non fixed width fonts was keeping
track of the proper position of everything.

Thanks,

Ewayne
Posted on 2003-07-08 22:15:46 by Ewayne