Hi Ewayne,

Nice too see your posts back. Vertical scrolling speed is cool. Nice idea, why M$ didn't think this? Anyway, i think, found something to fix.
Try this,

on any line do Shift+End

this work slow for me.

(win98)

Regards
Posted on 2003-07-09 10:33:42 by cakmak
Hi Ewayne,

I was highlighting and dragging to the right, but oftentimes I go too far or not far enough and accidently lift my finger when I don't mean to. Anyway, I would normally start from the right side then (since I'm already there) and work my way back towards the front rather than grab the scroll bar and start again from the left. But I could learn to live with it.

The disappearing highlighting and text is best illustrated with pictures:

1 - At the top is the default font/size/style, works fine...
2 - Second line is Arial/same size/style and visible highlighting disappears as I'm scrolling...
3 - Third is Lucida Handwriting/12/BOLD and visible highlight as well as part of the visible text disappears as I'm scrolling...and the farther to the right I scroll, the more text disappears (text grows shorter from the left side)...

However, when I back up a little (from the extreme right side) the text and highlighting appears normally as it should.
Posted on 2003-07-09 11:55:42 by gscundiff
To gscundiff & cakmak:

I tested the Non fixed width fonts on files that had enough lines
to force a vertical scrollbar and I forgot to set the scroll position
if there was no vertical scrollbar. So the Non fixed width fonts
problem should be fixed.

I'll see what I can do about continuing the scroll if you lift your
finger up to soon.

The End, Shift\End, Ctrl\End should work ok now.

You can go to the first post of this thread for the update.

Thanks,

Ewayne
Posted on 2003-07-10 09:11:41 by Ewayne
Hi Ewayne,

That seems to work better.

You mentioned you might try coding the scroll to the left also, but I found that if I scroll over towards the right of a long line (or go to the end of it for instance) then press and hold left button while I drag to the left...and go one line down with the cursor...it will scroll to the left (and go faster if right button pressed) just like scrolling to the right. But when the left end position is reached, and left button is still not released, it will reset itself to the extreme right side and start all over again.

I know it's not your intention and you haven't even gotten that far along with the scroll routine, but I thought I'd bring it to your attention.

Keep up the GREAT WORK !!
Posted on 2003-07-10 10:25:45 by gscundiff
To gscundiff:
That seems to work better.

Thats not good enough.

After you scroll right on a long line with the left mouse
button with or without the right mouse button and after you
have scrolled for awhile (don't release the left mouse button)
move the cursor to the left on the same line and when
you get within 100 pixels of the left edge of the edit window
it should go into a left scroll loop. Moving the cursor to the
right or releasing the left mouse button will stop the loop.

You don't need to drop down a line.

Let me know if it still does not work for you.

I've tested it on Win95, Win98, NT, and XP.

Thanks,

Ewayne
Posted on 2003-07-10 15:02:50 by Ewayne
Ewayne, it works now on my system..right and left. (I can still go down a line (or any number of lines) and scroll left but now it stops and holds at the front of the line like it should.)
Posted on 2003-07-10 22:02:45 by gscundiff
To gscundiff:

On long lines you can now initiate a left scroll loop
without mouse select scrolling to the right first.

Scroll a long line to the right with the horizontal scrollbar
and select a position on the line with the left mouse
button, while holding the left mouse button down move
the cursor to the left and when the cursor comes within
100 pixels of the left edge of the edit window it will go
into a left scroll loop. You can increase the scroll speed
by also pressing down the right mouse button. You can
stop the scroll by moving the cursor to the right or
releasing the left mouse button.

Let me know how it works.

You can go to the first post on this thread for the update.

Thanks,

Ewayne
Posted on 2003-07-11 19:28:11 by Ewayne
Hi Ewayne,

That works great...as advertised. Scrolls right and left equally well !
Posted on 2003-07-11 20:41:04 by gscundiff
Hi all;

You can go the the first post on this thread to download
AsmEdit5.zip.

It's the first step in rewriting AsmEdit.

Let me know how it works.

Thanks,

Ewayne
Posted on 2003-08-07 13:31:49 by Ewayne
Ewayne,

Crashes on start up,

Log data
Address Message
Process terminated, exit code FFFFFFFF (-1.)
BFF70000 Module C:\WINDOWS\SYSTEM\KERNEL32.DLL
BFF50000 Module C:\WINDOWS\SYSTEM\USER32.DLL
BFF20000 Module C:\WINDOWS\SYSTEM\GDI32.DLL
BFE80000 Module C:\WINDOWS\SYSTEM\ADVAPI32.DLL
82808000 Module C:\WINDOWS\SYSTEM\COMCTL32.DLL
7FE10000 Module C:\WINDOWS\SYSTEM\COMDLG32.DLL
7FCB0000 Module C:\WINDOWS\SYSTEM\SHELL32.DLL
70BD0000 Module C:\WINDOWS\SYSTEM\SHLWAPI.DLL
Different path, discarding .udd data
00400000 Module D:\ASMEDIT5\ASMEDIT5.EXE
Main thread with ID FFFA8235 created
New process with ID FFF99B71 created
Copyright (C) 2001, 2002 Oleh Yuschuk
Bookmarks sample plugin v1.06 (plugin demo)
Written by Oleh Yuschuk
Command line plugin v1.01
File 'D:\ASMEDIT5\ASMEDIT5.EXE'
OllyDbg v1.08 (intermediate version - under development!)


OS: Win98SE

Regards,

akyprian
Posted on 2003-08-07 14:29:47 by akyprian
Yup, it crashes on startup on Win98SE box as well:
ASMEDIT5 caused an invalid page fault in

module ASMEDIT5.EXE at 0167:0040e125.
Registers:
EAX=0000002b CS=0167 EIP=0040e125 EFLGS=00090206
EBX=00540000 SS=016f ESP=0064fd28 EBP=0064fe34
ECX=81739448 DS=016f ESI=81739448 FS=2baf
EDX=81739884 ES=016f EDI=810dff7f GS=0000
Bytes at CS:EIP:
80 3f 5c 75 02 eb 06 48 4f 0b c0 75 f3 83 c7 02
Stack dump:
00000000 81739448 5c3a4322 444e4957 5c53574f 6b736544 5c706f74 656d7361
35746964 6d73415c 74696445 78652e35 00202265 0282015f 9e568d7c 02820147


EDIT: Win2K SP4 too
Posted on 2003-08-07 16:38:17 by donkey
Sorry about that,

I thought if a program worked on XP it would work on
the other OS's, not true.

I had a local variable in my parse command line proc
that I forgot to zero out and it looks like XP zeros them out.

I posted an update on the first post.

Thanks,

Ewayne
Posted on 2003-08-07 20:36:55 by Ewayne
Ewayne,

Start Up is OK now,

akyprian
Posted on 2003-08-08 00:13:07 by akyprian
Hi Ewayne,

You should buy yourself a copy of VirtualPC. I bought one when I started to have problems between 9x and NT and find that it is extremely useful in testing as I don't need multiple development PC's. The $129.00 that it costs is minor when you weigh it against the fact that I can test on 4 different platforms with my laptop. The added functionality of shared folders and drag and drop file transfers really helps to automate the process. You can apparently even run linux on a VPC though I have never tried. I have had no problems with Win2K as a base OS and Win95/ Win98SE/ WinXP (XP is very slow but functional) as virtual PCs (and yes, I have valid liscenses for all the OS versions).

http://www.connectix.com/index_win.html
Posted on 2003-08-08 00:53:36 by donkey
To donkey,

Thanks for the information.

I have three other OS that I can test on,
but I just didn't bother to do it.

Ewayne
Posted on 2003-08-08 08:29:21 by Ewayne
Hi all,

I made some fixes to RichEdit44 and some additions to AsmEdit (AsmEdit5).

1. You can now have smooth mouse wheel scroll.
2. Print with syntax hilighting.
3. Change all functions and options.

I did not include all of the programs and files, (because of the attachment
size) so all of the features will not work. But you should still be able to give
it a good test.

I'm still working on the Alt + Numpad > 255 bug, the
main problem is displaying the DBCS. I don't know how M$ RichEdit V3
does it, I know it uses HexToUnicode which is no problem but I don't
know how to render it.

You can go to the first post on this thread for the update.

I will be posting the complete package on my web site soon.

Let me know it works.

Thanks,

Ewayne
Posted on 2003-09-03 14:43:59 by Ewayne
Just had a quick look,

1.Font color works OK if I choose from Format-Change color, but not If I change it from Format-Change font-Edit font. Same stands for line font.

2.File-Open As Hex, Choose Cancel, "Could not create or open requested file". Normally we should not see any messagebox.


If I find something else, I 'll let you know.

Regards,


akyprian
Posted on 2003-09-03 14:58:29 by akyprian
To akyprian;

I did not intend to have the Font dialog change the text colors,
I disabled that feature.

I fixed the open file cancel problem.

You can go to the first post on this thread for the update.

Thanks,

Ewayne
Posted on 2003-09-03 19:34:14 by Ewayne
Thos two ok now,

New one:

Use mousewheel, GPF's if there is no text in the editor. Win98SE

Regards,

akyprian
Posted on 2003-09-03 23:50:34 by akyprian
To akyprian;

I can not get it to fail under Win98, NT 4.0, or XP Pro/Home.

I've tried it with Smooth Scroll on/off, Font Zoom on/off.

Can you get it to fail every time you try it?

What are the steps that you take, do you just open AsmEdit and then
use the mouse wheel?

Thanks,

Ewayne
Posted on 2003-09-04 10:15:12 by Ewayne