To put the monitor into to power saving mode I did something like:


invoke SendMessage,HWND_BROADCAST,WM_SYSCOMMAND,SC_MONITORPOWER,2

Which was working well for a while... But now what I need to do is try to keep the monitor in power saving mode even when there's application activity (or at least keep the screen black and be in power-saving mode for as mush time as possible)... There should only be "activity" (never keyboard or mouse activity) about every 1/2 hour. So one solution I can think of is to keep the screen painted black and send the monitor into power-saving mode every hour or so. Obsiously this wouldn't be too "efficient" so... are there any other ideas on how to go about this?
Posted on 2003-04-30 00:38:37 by Soul~Drudge
hummm... windows should only bring the monitor out of power saving mode when there's activity of the mouse/keyboard kind... what causes the monitor to go back to power-on mode? application activity?
Posted on 2003-04-30 02:45:39 by f0dder
Thanks for the reply...

Scheduled tasks will bring it out... more specifically when I set up the comp to capture something on tv. It'll come out a minute before it starts recording (why?probally the way the ATI software schedules it, other than that I have no clue) and stays out of power saving mode completly.

The reason why I don't just turn off the monitor is because right now I assigned the program I was talking about above to a button on my ATI remote so I can turn the monitor off remotly. Now to be able to keep the monitor off, would be great.
Posted on 2003-04-30 09:06:06 by Soul~Drudge
hmm. power saving mode will usually react to hardware interrupts, afaik. BIOS will often let you assign which interrupts wake you up and which don't, but I think windows can/will override this. Look in your device manager - many devices will have a "power management" tab (well, on NT anyway). Check your video capture card - perhaps there's some interesting settings?

Just guesses though :(
Posted on 2003-04-30 09:10:25 by f0dder
If I were to guess, it sound like to me the screen saver kick in and the mode changed causing the monitor to wake up.

To test, just turn off your screen saver.

Regards, P1
Posted on 2003-04-30 12:31:10 by Pone