Afternoon, All.

Attached is a tentative example of the fifth DX8.1 Microsoft "tutorial", Textures.

Cheers,
Scronty
Posted on 2003-05-21 18:03:01 by Scronty
I installed DX8.1. When I tried running tut02 the first time, the screen went black and then recoved. After that nothing happens when I run any of the demos. OS=Win98SE
Posted on 2003-05-22 02:45:00 by eet_1024
Afternoon, eet_1024.

You say you've only just installed DX8.1? Have you tested any other DX8.1 proggys on it?

Run DXDiag.exe (start->Run...) and try the tests in there.

Does the attached Masm32 Matrices example work?

Cheers,
Scronty
Posted on 2003-05-22 04:52:36 by Scronty
No Rotation.
Posted on 2003-05-22 07:48:59 by Homer
Works for me.
Posted on 2003-05-22 07:53:04 by bitRAKE
xp 2600 patched with craptarded ati rage pro , amd 333, non rotato.
I also only have 48 meg of ram on this pissbox, and I've noticed in the past that sometimes rotation fails when my resources are low using code that worked 10 seconds ago without any changes - DX weirdness? Either the Timer or the matrix math code is failing - I can't see why either would have resource issues and yet I stand by my observation as a natural scientist.
Posted on 2003-05-22 08:21:40 by Homer
Afternoon, EvilHomer2k.

Does it rotate when you're not running *anything* else on your system?

48megs ram seem mightily inadequate for running XP ;). Even Win98 ran best when on 64meg ram, and struggled with 32meg.

I'm on XP Prof myself, so it cannot be an OS weirdness.
2.4gighz and 512 ram. ATI Radeon 9000 (with drivers d/loaded from ATI, not the manufacturer).

ummm....

xp 2600? what's that? You also mention that it's on an AMD 333! WTF!!1111 OMG !!.

Cheers,
Scronty
Posted on 2003-05-22 17:34:30 by Scronty
dxdiag worked fine.

The fasm Direct Draw example also works.

I traced vertices.exe with OllyDbg.

In routine InitD3D, the call at line 173 returns 0x88760862
     comcall pD3D,CreateDevice, 0, 1, [hWnd],\

020h,\
d3dpp, pd3dDevice
cmp eax, NULL
jne InitD3DFinished
Posted on 2003-05-23 02:15:37 by eet_1024
Afternoon, eet_1024.

Did the attached Masm32 Matrices example above work?

Cheers,
Scronty
Posted on 2003-05-23 05:00:15 by Scronty
Scronty, nope, I can run it fresh from a reboot and it won't rotate.
My resources are handled virtually and automatically by a huge swapfile (thank you xp)
I have around 300 virtual meg of ram.
Still, it can play up from time to time but only when pressed.
2600.1106 was a vendors edition of xp.
Since it as been patched up, its sitting at 2800.1106
Its just a versioning number, but a cute one :)
Posted on 2003-05-23 07:09:06 by Homer
Nope, this program get an ERROR_INVALID_PARAMETER (00000057) from the call to CreateWindowExA.

It then appears to fail at the same point as vertices.
Posted on 2003-05-24 21:39:54 by eet_1024
Scronty, I'm getting the feeling that it's because the world matrix wasn't initialized with Identity matrix values ... you think that could be it? I'll try it and let you know...
Posted on 2003-05-25 12:35:39 by Homer