I love Radasm (2.0.2.4) Great work :alright:
I love Radasm (2.0.2.4) Great work :alright:
I love Radasm (2.0.2.4) Great work :alright:
I love Radasm (2.0.2.4) Great work :alright:

Now the problems :grin:
First, when opening a source file, it opens to c:\masm32, could I change it to sthg else than this, could you please add a source directory option (for me, it is c:\asm).
Second, most bothering : when I use "Recent files" option, it will not compile. Normal : current directory is c:\masm32 at the beginning so Radasm will launch Masm32's batches with parameters so that it will try to compile a c:\masm32\mysource.asm :(
Third, when I pick up a new file after c:\asm\mysource.asm, say c:\common\newfile.asm, the main asm file cannot compile anymore (since Radasm changed the current directory to c:\common and passes it to Masm32). I must close/reopen mysource.asm. I use Win95/masm32 v8/std options for Masm32's build. What is the trick, please ? Thx. And keep in mind that...

I love Radasm (2.0.2.4) Great work :alright:
I love Radasm (2.0.2.4) Great work :alright:
I love Radasm (2.0.2.4) Great work :alright:
I love Radasm (2.0.2.4) Great work :alright:

:)
Posted on 2003-06-13 05:56:33 by valy
Are you creating projects for your asm files ?

It seems that you are using just the bare asm files and compiling them with the default no project setup. You should create a project for your code that way when you select open project it will display your projects folder and the rap file will control all of the other things that you have talked about.
Posted on 2003-06-13 06:48:43 by donkey
Hi donkey

No, I still do not use project mode.
I'd have liked not to work with project option (tiny but secure C: since C: is on a tiny SCSI harddrive !
(fed up with IDE crashes)
Posted on 2003-06-13 06:54:56 by valy
Well, for the file question, be sure that the asm file your are compiling (or the main file) is in the mdi child that is topmost (i.e. displayed) as the default project uses this filename in it's build command. You may want to manually edit the build for MakeDefNoProject in the masm.ini file, it is used to generate the command lines. The help file has a page in the advanced section on how to edit project types.
Posted on 2003-06-13 07:02:33 by donkey
Yes, sure : it is the one displayed.

Thx donkey, I'll look at help about MakeDefnoproject
Posted on 2003-06-13 07:06:40 by valy
Hi valy

You might want to check out Options / File Browser and set C:\asm at the top of the list.

KetilO
Posted on 2003-06-13 08:59:40 by KetilO
Hi Ketilo

Thx, it is better with it.

Bye
Posted on 2003-06-13 09:18:10 by valy