the folders are ok, since assemble works and the .asm and .obj are in the same folder.
i also tried to use 3=$.com,OT,$B\tlink16.EXE /t ,$.obj
when i tried to use link16.exe in command.com, a .com file was not created.
hmm i really dont know what could be wrong.
Posted on 2003-06-27 08:18:30 by wasiliy
Have you checked to make sure that there is an OBJ file ? This one will send the actual tlink.exe command executed to the RadASM output window. tlink16 is just a commandline parser, it does not actually link the program, you have to use it with RadASM or it does nothing at all so it is obvious that it did nothing if you used it from Command.com
Posted on 2003-06-27 11:22:12 by donkey
Hi wasiliy

Here is a tasm dos project. Have a look at the project options.
If you are running NT/2k/XP you should be able to link to output window.
In that case change the CT parameter to OT on the link command.

KetilO
Posted on 2003-06-27 17:05:31 by KetilO
the link command in the project and the link command in my .ini differed in one character:
instead of the O
3=$.com,OT,$B\tlink.EXE /t ,$.obj
the project had a C
3=$.com,CT,$B\tlink.EXE /t ,$.obj

now i dont get an error and radasm says everything is fine but no .com is created at all.
i also tried to create an .exe but i had the same problem.
i also searched my harddrive for the .com and .exe, i didn't find anything.

please be patient with me =) and thank you very much for helping.
Posted on 2003-06-28 02:54:26 by wasiliy
Hi wasiliy

The problem is still the quotes that RadASM adds to support spaces in filenames.
The only way to avoid it is:

3=YourFile.com,CT,$B\tlink.EXE /t YourFile.obj

Replace YourFile with the filename. If the filename is more than 8+3 chars then use the short filename.

If you are running on NT/2k/XP you can replace CT with OT.

KetilO
Posted on 2003-06-28 03:07:39 by KetilO
ok now it works but cant you fix it, so that it works with ,$.*** ???
please =)
Posted on 2003-06-28 03:44:29 by wasiliy
Hi wasiliy

No, dos and 16bit is dead.
You should put a few hours into studying projects and make.exe that came with tasm. This will solve your problems.

KetilO
Posted on 2003-06-28 03:50:56 by KetilO
16bit is dead??? thats blasphemy =)
come on, i bet it's not that difficult for you.
Posted on 2003-06-28 04:09:19 by wasiliy
True, but I guess learning how to use make or write a batch file is for you.

KetilO
Posted on 2003-06-28 04:57:21 by KetilO
i use batch files usually but they are not as comfortable as your IDE, i really like the funky psychedelic colors =)
there are a lot of IDEs out there but they contain too many bugs or dont support working with single files. so yours is the best i've found. thats why i asked.
Posted on 2003-06-28 05:06:40 by wasiliy
Using make or a batch file to build does not in any way exclude using RadASM.

KetilO
Posted on 2003-06-28 07:04:42 by KetilO
come on, dont you want to be my hero??? bruce lee always has been my role model but you could replace him easily by fixing that for me =)
just kidding. but thank you anyway for helping me in finding that other solution.
Posted on 2003-06-28 10:07:43 by wasiliy
for .com files...

hi,

if you dont care .txt file type, in your last project file (.rap)



Menu=0,1,1,1,1,1,1,1,0,0
1=4,O,$B\brcc32.exe -r -i"$I" -v,1
2=3,O,$B\tasm32.EXE /I"$I"
3=8,C,$B\tlink.exe /t ; << notice "8" and without "," or "$"
4=0,0,,5
5=
7=0,0,C:\Program Files\OllyDebug\OllyDbg,5

and,


0=aaa.rap
1=aaa.rc
2=aaa.asm
3=aaa.obj
4=aaa.res
5=aaa.com
6=aaa.def
7=aaa.dll
8=aaa.com ; << here is yours ;)
9=aaa.lib
10=aaa.mak
11=aaa.hla

did you get the idea, the same thing for .exe. Notice commandline parser. And i suggest you create a .pif file for tlink.exe, this is better.
I tested this!


good luck

edit: if you need i can send the simple project.
Posted on 2003-07-02 19:44:17 by cakmak