lycos smtp server does not seem to work, or at least it retuns an error mail. please find bellow the error mail send back( to the mail from: e-mail ).

please note that i telnet to the server and tried it there with the same results. also note that i've tested it on yahoo smtp and it works..
I will appreciate any hints.

-----------------returned mail----------
Subject:
Returned mail: Bad usage

The original message was received at ....blah..
(DST)
from blah blah blah (may be forged)
----- The following addresses had permanent fatal errors -----
x_ray@mailcity.com ----- Transcript of session follows -----
500 x_ray@mailcity.com... Bad usage
Attachment: Message/delivery-status
Reporting-MTA: dns; mailbox-7.caramail.com
Arrival-Date: Wed, 10 Oct 2001 13:20:05 +0200 (DST) Final-Recipient: RFC822; x_ray@mailcity.com
Action: failed
Status: 5.5.4
-------------------------------------------

also note that my e-mail was originally at mailcity but now is everything under lycos. i tried sending with both domains with no success...
Posted on 2001-10-10 06:35:54 by Ray
500 is an internal server error. Maybe their STMP server is down.
Posted on 2001-10-11 22:15:27 by eet_1024
First, it's normal for free smtp to be down... it sucks, but that's how
life is (you *should* really use your ISP SMTP anyway :). Second,
I'd go to lycos and have a look, they might have changed some stuff
around.
Third, wouldn't this post be more appropriate in the heap section?
It's not very programming related to me :).
Posted on 2001-10-11 22:40:05 by f0dder
well,

I dont believe that their server is down cause i've been having this problem for almost a month now.

heap section? ..maybe
Posted on 2001-10-12 06:16:11 by Ray