Please test it and taste it.

BTW. i spent month on a project that could be made in few hours in VB. God i love assembly :tongue:
Posted on 2003-07-05 19:01:00 by AceEmbler
It is working on 2k sp3 (just not sure what the words mean).
Posted on 2003-07-05 20:11:24 by roticv
ditto. running on Win2K SP3. could guess what the words mean, but i'm not going to :p it runs :)
Posted on 2003-07-05 21:45:50 by jademtech
i should post this code in a Crusade. I made simple MessageBox in C and it's size is 24,5 KB look at my prog it's 16,3 KB (inside 1 KB beckground bitmap)
Posted on 2003-07-06 06:21:45 by AceEmbler
Works in Win2K SP0 (LOL! , I have no service pack installed), but it runs fine.
Posted on 2003-07-06 13:05:03 by x86asm
why shouldnt btw what is service pack ??
Posted on 2003-07-06 15:55:04 by AceEmbler
works well on Win95C

. i spent month on a project that could be made in few hours in VB. God i love assembly
if you work for more than 10 years in asm, you will feel opposite - this thing had took me in asm three lines, but a number of headstands in C / VB ... :)
Posted on 2003-07-07 08:07:38 by beaster
Hi,

runs well under NT4 - SP6a.

Bye Miracle
Posted on 2003-07-07 08:39:38 by miracle
win2k sp4 - :alright:
Posted on 2003-07-07 10:35:26 by arkane
Seems to work fine in Win98... is it supposed to use the system default font?
Posted on 2003-07-07 11:36:35 by QvasiModo
Running Win98...

I get an illegal operation when I do the following:

1) Click on a blank field
2) Roll the mouse down to highlight an item
3) Roll the mouse back up to the blank field
4) Click the mouse on the blank field

Hopefully you can understand what I mean...if not, I can capture some screenshots to demonstrate
Posted on 2003-07-07 17:27:12 by sirchess2
It's working on Win XP.
Posted on 2003-07-08 02:56:01 by Vortex
Work fine on damaged instalation of Win 95 OSR 2 :grin: :grin: :grin:

Only <TAB> did not switch to next control, but maybe you did not make this.
I think you must make the design more "mono-type". I mean, there are some "flat" looking static fields with dark gray background color (they looks like flat buttons) and 3D-looking controls. I think you must make static fields transparent and without borders.

Design and behaviour are the first thing in every program.

Regards
John Found
Posted on 2003-07-08 05:31:19 by JohnFound
Originally posted by sirchess2
Hopefully you can understand what I mean...if not, I can capture some screenshots to demonstrate



Yep it looks like u have to.
Posted on 2003-07-08 17:57:05 by AceEmbler

Hopefully you can understand what I mean...if not, I can capture some screenshots to demonstrate


if you can't figure out how to do a screenshot, i know of this *great* little shareware program that can help you... :grin:

(if you don't get it, ignore it... just me being stupid - not making fun of you in any way :) )
Posted on 2003-07-08 22:41:52 by jademtech
I thought that this gray static fields looks much better than this transparen one. Did you realy think that this is a button ??


and yes TAB did not change the control

and yes i was not changing Fonts


Do you think i should make this two things ??
Posted on 2003-07-09 07:27:29 by AceEmbler
Here's the screenshot.

I hope it isn't my system...I just reformatted and re-installed Windows within the past week :eek:

Here's the details from the illegal op, if that helps:
---
ADDRBOOK caused an invalid page fault in
module ADDRBOOK.EXE at 015f:00401a60.
Registers:
EAX=00000000 CS=015f EIP=00401a60 EFLGS=00010246
EBX=fffffffe SS=0167 ESP=0063f994 EBP=0063f9b4
ECX=00000ff4 DS=0167 ESI=00750000 FS=2927
EDX=0074f00c ES=0167 EDI=00405308 GS=0000
Bytes at CS:EIP:
8a 04 11 41 83 f8 00 75 f5 8b 04 11 8b f2 83 c1
Stack dump:
0063fa5e 0063fa14 00008a82 0063fa14 00008a82 0063fa5e 0063fa0c 004019fc 0063fa0c 00401a10 00000354 ffffffff 00405308 0074f00c 0772169f 07720002
---

/Edit: To mods - I would've used a URL to the image, except I don't have a web server/site to upload it to at this time. If anyone here with a web site could put the image there, I'd be happy to post a link instead
Posted on 2003-07-09 10:34:40 by sirchess2
hmmm this is mysterious.

Please download this repaired version and tell me if this bug is still appearing.
Posted on 2003-07-09 14:13:04 by AceEmbler
The new version still doesn't work on my computer

I tested it on a friend's tho (WinXP), and it works fine there.

It's probably something screwy with my system :/
Posted on 2003-07-09 22:05:50 by sirchess2
...or perhaps somebody is forgetting to preserve registers...?
Posted on 2003-07-10 01:42:33 by f0dder