One extremely minor point, this will not collapse properly:
;===========================================

; E-Z Unicode By NaN, 2002
;==============================================
UNICODE_TEXT TEXTEQU <LABEL BYTE>
LL macro btext
LOCAL cnt, va, vb, LineText, data1
LineText TEXTEQU < dw >
va = 1
vb = 1
cnt equ @SizeStr(<btext> )+1
WHILE va LT cnt
if vb LT 20
data1 SUBSTR <btext>, va, 1
LineText CATSTR LineText, <'>, data1, <',>
else
vb = 1
LineText SUBSTR LineText, 1, @SizeStr(%LineText)-1
&LineText
LineText TEXTEQU < dw >
data1 SUBSTR <btext>, va, 1
LineText CATSTR LineText, <'>, data1, <',>
endif
vb = vb + 1
va = va + 1
ENDM
LineText SUBSTR LineText, 1, @SizeStr(%LineText)-1
&LineText
endm

and the following :
Posted on 2003-07-25 13:45:44 by donkey
I think I have found a problem in RadASM...
When I try to build a DLL project, the contents of my .def file seem to be cleared.
I don't really know if the problem is in RadASM or not, but I tried hutch's QuickEditor and it worked fine.
Please take a look at this thread, and tell me if it's a bug in RadASM or it's just that I did something wrong...
http://www.asmcommunity.net/board/showthread.php?&threadid=14463
Posted on 2003-07-25 14:56:09 by QvasiModo
QvasiModo

I'm really beginning to regret posting that addin, I use it constantly and find it extremely useful but nobody ever does a search. The answer to your question...

http://www.asmcommunity.net/board/index.php?topic=14448

Use the version at the bottom of the thread, the problem was fixed some time ago

Ketil,

You really have to update the distro file :)

Actually I was thinking that for the most part there is no need to include the AddIns in the upgrade package. For myself everytime I upgrade I have to preserve my MSDNHelp as my version with Help2 support is overwritten. There is no need to include any addins except the ones that have been upgraded or added. Would save a little bandwidth as well.
Posted on 2003-07-25 16:13:47 by donkey
I have to say, your design is fantastic!

I easily added two more code block items for my OOP model, and i can now open and collapse the Class definitions (Mehtods/Variables) just like a structure or a proceedure! :grin: :grin:

Keep up the good work KeltIO!
:alright:
NaN
Posted on 2003-07-26 10:44:40 by NaN
Think i found a possible bug. If not, im not sure where the button or menu item is to refresh this.

Sometimes, after compiling and resolving errors, i find that the error highlights remain, even though the error was fixed, and the program is running. I tried "Refresh Properties" but this has no effect on they error highlighting..

PS: Just dawned on me. I turned on "Flicker Free Syntax Highlighting" this morning. Its most likely in that code, since i didnt notice this problem until today. :alright:

Here is a Pic of the problem (This source is bug free)
Posted on 2003-07-26 13:12:41 by NaN
I found another problem. This one i find kinda serious.

I just finished running in circles pulling my hair out trying to figure out what is going on with the errors im fixing from a compile. I would fix an error or two and recompile to see the remaining errors. I often do this since adjustments to fix an error often make the pointers to the remaining errors become out of place.

So after doing this two or three times i find out that some errors are still there. Ones that i thought i fixed.

Only after doing this for about 10 min did i realize that RadASM opens another TAB at the top UNCONDITIONALLY when you double click on the error list in the output window. What i found i was doing was editing *some* errors from each open window (since i didnt watch the tabs at the top when i double clicked on the error).

IMHO, you should fix this. If the file is already open, then RadASM should jump to the open TAB, not open another copy of the same file/tab. All i can say is it needlessly made everything confusing while debugging multiple files at once. It was not a pleasant experience <lol>

Sorry to dump this on you ;) .
:NaN:
Posted on 2003-07-26 16:44:03 by NaN
Hi NaN,

I couldn't duplicate the bug so maybe I'm misunderstanding. When there is an error and the line number is displayed in the output window, you double click the line number (or file name ) and it opens another instance of a file that is already open. I found that everything reacted the way it should have, if the file was alreaady open it switched tabs, if it was not, it opened the file.
Posted on 2003-07-26 16:58:43 by donkey
Well that was what happened..

Albeit, most of the errors where generated from macro's (OOP model). But the soure that contained the macro statement in code was being opened over and over...

:NaN:
Posted on 2003-07-26 17:32:59 by NaN
Hi all

New upload at the top.

- Fixed 'include macro.inc' marked as code block bug.
- Fixed bugs related to error bookmarks.

KetilO
Posted on 2003-07-27 08:22:02 by KetilO
Hi NaN

The only way I can think of that makes RadASM open a second copy of a file is if you include it using short pathname.

Example:

Filename: My Include File.inc

In your source:

include MyIncl~1.inc

Can this be the cause? If not maybe you can give me the filenames etc. so I can reproduce the bug.

KetilO
Posted on 2003-07-27 08:51:51 by KetilO
Here is the 7 step method to generating the same bug with the attached source:

    [*]Open the project (mine loads automatically)
    [*]Open File -> Mod Dir -> FileData.asm
    [*]Double Click on "FileCompare.asm" in the project bar
    [*]Double Click on "FileCompare.inc" in the project bar
    [*]Force an error in "FileData.asm" (first tab). Goto line 58 and change the last tag "FileData_setFlag_Funct" to "FileData_setFlag_Functh"
    [*]Recompile the project (Build All)
    [*]In the output box double click on Line #2: ".\mod\FileData.asm(58) : error A2006: undefined symbol : FileData_setFlag_Functh"


    You should now have FOUR tabs open:
Posted on 2003-07-27 11:59:39 by NaN
Hi NaN

The way you include files is the cause.



include .\mod\NObjects.inc
include .\mod\CString.asm
include .\mod\FileData.asm
include .\mod\ILink.asm
include .\mod\LnkLst.asm


Change it to:



include mod\NObjects.inc
include mod\CString.asm
include mod\FileData.asm
include mod\ILink.asm
include mod\LnkLst.asm


until I can make a fix that handles it.

KetilO
Posted on 2003-07-27 13:28:38 by KetilO
Hi all

New upload at the top.

- Fixed dblclick on error in outwindow bug.
- Added tooltip while creating initialisized structure.

Example:

lfnt LOGFONT <

Will show a tooltip containing LOGFONT structure items. Simplifies creating initialisized structures.

KetilO
Posted on 2003-07-27 14:50:13 by KetilO
Thanks for putting up with me :alright:

:NaN:
Posted on 2003-07-27 15:27:56 by NaN
Hi Ketil, I have a problem with the infotip for structures:
Using the following structure:
COMBOBOXINFO STRUCT

cbSize DWORD ?
rcItem RECT <?>
rcButton RECT <?>
stateButton DWORD ?
hwndCombo DWORD ?
hwndItem DWORD ?
hwndList DWORD ?
COMBOBOXINFO ENDS


I get the following infotip:
Posted on 2003-07-27 15:36:59 by donkey
Probably related to substructures, the stucts with simple types seem fine but when you introduce a substructure there are problems :
INPUT STRUCT

itype DWORD ?
UNION
ki KEYBDINPUT <>
mi MOUSEINPUT <>
hi HARDWAREINPUT <>
ENDS
INPUT ENDS
Posted on 2003-07-27 16:04:16 by donkey
Hi donkey

Yes the bug is related to nested structures and could have been fixed. There is however no way to support unions so I will remove it. Too bad as it would have been very helpful with a tooltip.

KetilO
Posted on 2003-07-27 17:45:54 by KetilO
Yeah, it would have been an excellent feature, I am constantly making errors when typing the structure contents out this way and a reference infotip would be nice. Is there a way to disable it when a union is present in the structure ? Say if the UNION keyword is encountered it just doesn't display anything. After all only a small percentage of structures contain unions, it would be a shame to scrap it for around 100 out of 1166 structures.
Posted on 2003-07-27 18:10:22 by donkey
Hi donkey

The union info is lost during parsing (also in the .api file) so there is no easy way I can know if there is a union.
Tooltip on structures containing unions will be displayed wrong. But I guess as long as the user knows it will be OK.

KetilO
Posted on 2003-07-28 04:50:46 by KetilO

QvasiModo

I'm really beginning to regret posting that addin, I use it constantly and find it extremely useful but nobody ever does a search. The answer to your question...

http://www.asmcommunity.net/board/index.php?topic=14448

Use the version at the bottom of the thread, the problem was fixed some time ago


Thanks, donkey!

Anyway, I'm still having a problem when building the DLL...
7,OT,$B\LINK.EXE /SUBSYSTEM:WINDOWS /RELEASE /DLL /NOENTRY /SECTION:.hook,S /DEF: /LIBPATH:"$L",3

Returns this error:
Assembling: HookLib.asm
C:\Masm32\Bin\LINK.EXE /SUBSYSTEM:WINDOWS /RELEASE /DLL /NOENTRY /SECTION:.hook "S /DEF: /LIBPATH:"C:\Masm32\Lib"" "HookLib.obj"
Microsoft (R) Incremental Linker Version 5.12.8078
Copyright (C) Microsoft Corp 1992-1998. All rights reserved.

LINK : fatal error LNK1181: cannot open input file "S /DEF: /LIBPATH:C:\Masm32\Lib.obj"

Make error(s) occured.

The command line does not seem to be parsed correctly... What I am doing wrong this time? :confused:
Posted on 2003-07-28 10:33:34 by QvasiModo