Hi all

Help me test RadASM 2.0.3.2 for bugs.

Whats new:

- Integrated hex editor (remove HexVU addin).
- Fixed Versioninfo bug (only partially updated the .rc file).
- Made changes to how dialog editor saves controls in the .rc file.
-- All controls saved as type CONTROL.
-- Important: If changing old dialogs then listboxes might need Notify to be set to TRUE.
- Added Notify option to several controls.
- Several minor changes / bugfixes.

KetilO

08-15-2003,3 dl,Fixed code properties bug reported by Morris, also fixed code property bug where RadASM would GPF if first word in a file was a code property word.
08-17-2003,26 dl,Fixed a selection paint bug. Added more controls (HotKey, Pager, ReBar).
08-17-2003,16 dl,Fixed a controls caption bug. A controls caption is now updated while typing.
08-18-2003,28 dl,Added tab action option on code complete list. Fixed an EN_SELCHAGE bug.
08-19-2003,31 dl,Added new styles to toolbar and statusbar. Made some changes to RadASM's toolbars. Added position in statusbar on hex editor. Did some work on rebar demo.
08-20-2003,31 dl,Added more functions to info tool (dialog and hex edit). Fixed a bug in dialog edit where a window handle could be resized to the size of the dialog.
08-21-2003,32 dl,Fixed api tooltip bug. Fixed toolbox paint bug. Made changes to RadASM toolbars colormapping.
08-25-2003,62 dl,Improved hla support. Made the release.

IMPORTANT:
You must previously have installed 2.0.3.1
Posted on 2003-08-15 13:24:01 by KetilO
Hi all

New upload.

- Fixed a serious bug where RadASM would GPF if first word in a file was a reserved code property word.

KetilO
Posted on 2003-08-15 15:20:55 by KetilO
Hi Ketil,

While your adding controls how about the Pager and Hotkey controls ?

Edit: Oh, and a rebar control would be nice.
Posted on 2003-08-15 16:06:14 by donkey
KetilO, After 15-Minutes from using the new ver.

1- As you can see in the pic, there's sth with the selection, when i select sth & the move to another place to select it, both are selected :D can u understand? is this normal??

2- I encounter a strange funny bug, sometimes (really didn't discover when exactly this happen) when i type sth in the code editor, the text that i enter is written in different place, n the same thing, when i try to press (backspace) sometimes, it deletes in the wrong place.. Is this normal??

3- When selecting some lines and press (BACKSPACE) they are not deleted if the (INS) key is on.

:alright:
CuTedEvil
Posted on 2003-08-16 04:12:47 by CuTedEvil
Hi CuTedEvil

You seem to have a paint problem. Try to change the Flicker free drawing option.

KetilO
Posted on 2003-08-16 05:36:25 by KetilO
Same problem, KetilO :(

BTW: Another thing, I get this on the start
Error in:
L:\masm32\RadAsm\masm.ini
Code
$-,endp,proc
Error in:
L:\masm32\RadAsm\masm.ini
Code
$-,{C},equ
Error in:
L:\masm32\RadAsm\masm.ini
Code
$-,{C},db,dw,dd,dq,df,dt,byte,word,dword,qword,<?>,{?}
Error in:
L:\masm32\RadAsm\masm.ini
Code
$-,endm,macro
Error in:
L:\masm32\RadAsm\masm.ini
Code
$-,ends,struct,struc
Error in:
L:\masm32\RadAsm\masm.ini
Code
$-,endp,proc
Error in:
L:\masm32\RadAsm\masm.ini
Code
$-,{C},equ
Error in:
L:\masm32\RadAsm\masm.ini
Code
$-,{C},db,dw,dd,dq,df,dt,byte,word,dword,qword,<?>,{?}
Error in:
L:\masm32\RadAsm\masm.ini
Code
$-,endm,macro
Error in:
L:\masm32\RadAsm\masm.ini
Code
$-,ends,struct,struc
Error in:
L:\masm32\RadAsm\masm.ini
Code
$-,endp,proc
Error in:
L:\masm32\RadAsm\masm.ini
Code
$-,{C},equ
Error in:
L:\masm32\RadAsm\masm.ini
Code
$-,{C},db,dw,dd,dq,df,dt,byte,word,dword,qword,<?>,{?}
Error in:
L:\masm32\RadAsm\masm.ini
Code
$-,endm,macro
Error in:
L:\masm32\RadAsm\masm.ini
Code
$-,ends,struct,struc

I haven't changed masm.ini since the installation. Wut's with it??

CuTedEvil
Posted on 2003-08-16 06:13:27 by CuTedEvil
That's the older format for the [code] section, replace it with this:

As Ketil had said above you had to be running RadASM 2031 to be able to use this version. So you have to use the 2031 ini file format. There were changes from the ealier versions.

[CodeMacro]
;KeyWord,InsertBeforeActiveLine,InsertAfterActiveLine
;{I}=Copy indent from keyword line
;{C}=Cr
;{S}=Space
;{T}=Tab
;{$}=Copy Proc/Struct Name
;The macros are set up to assume AutoIndent on
1=.if,{T},{C}{I}.endif
2=.else,{T},
3=.elseif,{T},
4=.while,{T},{C}{I}.endw
5=$ macro,{T},{C}{I}endm
6=$ proc,{T}{C}{I}{T},{C}{I}{T}ret{C}{C}{I}{$} endp
7=$ struct,{T},{C}{I}{$} ends
8=$ struc,{T},{C}{I}{$} ends

[Code]
Code=$ endp,$ proc
Const={C},$ equ
Data={C},$ db,$ dw,$ dd,$ dq,$ df,$ dt,$ byte,$ word,$ dword,$ qword,$ <?>,$ {?},$ <>
Macro=endm,$ macro
Struct=$ ends,$ struct,$ struc

[CodeBlock]
1=$ proc,$ endp,,,6
2=.if,.endif,.elseif,.else,0
3=.while,.endw,.break,,0
4=$ struct,$ ends,,,6
5=$ struc,$ ends,,,6
6=$ macro,endm,,,14
7=.data,.*,,,0
8=.data?,.*,,,0
9=.const,.*,,,0
Posted on 2003-08-16 06:54:24 by donkey

Same problem, KetilO :(


colors

when i type sth in the code editor, the text that i enter is written in different place

seems to me, when I press mouse some where in text, and after that press it in the first column of another string
or use ctrl+V, etc

BTW: Another thing, I get this on the start

so did I

thanks, donkey !

Win XP home 5.1.2600.1106 (xpsp1.020828-1920)
:(
Posted on 2003-08-16 07:49:13 by S.T.A.S.
Hi there,

I have 2 other display bugs:

before resize:


after resize:



And the second one is related to selecting text. First, select all text:


then move your text down a bit (using the scrollbar)


and then deselect text by clicking anywhere in it:



I noticed this when I selected all text, then moved to the end of the file (using the scrollbar) and then cancelled selection - the top line remained as if it was still selected. I then tried to actually select the top line and noticed, that on selecting the text moved down by one pixel. That pixel was the cause for not un-highlighting the selection - the top line was not 100% visible (it missed that 1 pixel).
Posted on 2003-08-16 07:57:26 by Morris
@donkey: :alright:

One problem solved. Still the main (selection) problem..

@ S.T.A.S. : I dunno how 'colors' are my problem.. I believe it's selction & painting problem.. dunno :confused:

CuTedEvil
Posted on 2003-08-16 13:14:32 by CuTedEvil
Hi CuTedEvil

Download RadASM 2.0.3.1 from my web site. Then you can update to 2.0.3.2

KetilO
Posted on 2003-08-16 16:34:10 by KetilO
KetilO, :alright:

I'm downloading right now (it wasn't there yesterday :rolleyes: )
I'll tell ya if my problem still exists. =)

:alright: Works perfect, very nice work, KetilO

CuTedEvil
Posted on 2003-08-17 03:21:39 by CuTedEvil
Hi all

New upload at the top.

- Added tab action option on code complete list.
- Fixed an EN_SELCHAGE bug.

KetilO
Posted on 2003-08-18 04:11:25 by KetilO
You Rock ;)

This is better than i expected.. I like the added touch of jumping to the first letter that matches after a tab! Thanks alot KeltIO!!

:NaN:
Posted on 2003-08-18 19:41:36 by NaN
Great !

Thanks for the new controls. Now I just have to get rid of a few CreateWindowEx functions in my program and replace them with integrated ones :alright:
Posted on 2003-08-18 19:56:37 by donkey
The properties window still not working for me in 2.0.3.1 and the 2.0.3.2 update. I downloaded the update to 2.0.3.1 and not the full new installation though.
Posted on 2003-08-19 01:29:31 by xkardisx
Back to 2.0.9.2 for the moment. :x
Posted on 2003-08-19 01:32:18 by xkardisx
Just a small suggestion. In the hex view, could you add the offset that the cursor is at in the status bar, similar to the edit control.

eg. Offset: 1234 (0x4D2)

Also, a goto offset might be good for this window, rather than goto line.

Thanks

Nick
Posted on 2003-08-19 04:07:56 by Nick
Hi xkardisx

Unzip iniFiles.zip or download the full package and you shoud be fine.

KetilO
Posted on 2003-08-19 05:40:19 by KetilO
Hi Nick

I will add position in statusbar. The goto line will have to do for now.

KetilO
Posted on 2003-08-19 05:41:54 by KetilO