Greetings

I have been having trouble from the get go with having these 2 programs coexist peacefully.

Now with version 2.0.3.1 of RadAsm it keeps throwing these errors when I attempt to start a HLA program...



Error in:
C:\RADASM\hla.ini
Code
-$,end,begin
Error in:
C:\RADASM\hla.ini
Code
$-,;,:=
Error in:
C:\RADASM\hla.ini
Code
-$,#endmacro,#macro
Error in:
C:\RADASM\hla.ini
Code
$-,endrecord;,record


I have been looking for some answers here, in Hutch's masmforum and in Randy's site, but have not found anything yet as to what the changes have been to those sections and how to correct them.

I do love tinkering in hla and would love to reliably use Keito's RadAsm for my IDE...I see so much promise. BUT if I cannot get things to work correctly.without complaint and without pulling my hair out them I may have to take up another hobby.....maybe creative flower bombing woould be an interesting sport....:rolleyes:
Posted on 2003-08-21 10:20:19 by Damius
You must use the new format for ini files. There is a readme included with the 2031 release that details the changes to the ini files in your help folder called CodeBlock.txt, it will tell you what changes need to be made. The reason for this was to make the autocomplete more robust, it was necessary to make some fundamental changes to the ini files.

Changes to HLA.INI

[Code]
Code={C},procedure
Macro=#endmacro,#macro
Const=;,$ :=
Struct=$ endrecord;,$ record

[CodeBlock]
1=begin,end,,,6
2=if,endif,elseif,else,0

[CodeMacro]
1=begin,{T}{C}{I}{T},{C}{C}{I}end {$}
2=if,{C}{I}{T}, {C}{C}{I}endif;
3=elseif,{C}{I}{T}
4=else,{C}{I}{T}
5=while,{C}{I}{T},{C}{C}{I}endwhile;
6=repeat,{C}{I}{T},{C}{C}{I}until( expr );
7=for,{C}{I}{T},{C}{C}{I}endfor;
8=forever,{C}{I}{T},{C}{C}{I}endfor;
9=foreach,{C}{I}{T},{C}{C}{I}endfor;
10=try,{C}{I}{T},{C}{C}{I}exception{C}{C}{I}endtry;
11=switch,{C}{I}{T},{C}{C}{I}endswitch;
12=$ record,{C}{I}{T},{C}{C}{I}{$} endrecord;
13=union,{C}{I}{T},{C}{C}{I}endunion;
14=class,{C}{I}{T},{C}{C}{I}endclass;
15=#macro,{C}{I}{T},{C}{C}{I}#endmacro;
16=#if,{C}{I}{T},{C}{C}{I}#endif
17=#while,{C}{I}{T},{C}{C}{I}#endwhile
18=#for,{C}{I}{T},{C}{C}{I}#endfor
Posted on 2003-08-21 13:22:28 by donkey
It seems I'm too late:)... but anyway

I also added section:



1=begin,end,,,6
;2=if,endif,elseif,else,0
;3=while,endwhile,,,0

I commenting out if,endif,elseif,else (collapsing if-endif-else-endif blocks) becouse it is too buggy
Posted on 2003-08-21 13:25:02 by Green Joe
ok....

I cut and pasted into the hla.ini file the code you supplied donkey, removing the old bits first...(and I did then go throgugh the txt files again to see what was what...)


Now the compiler aborts saying:

"Error during process creation
nmake build"
:confused:

On the simple Hello World program supplied with hla...:mad:

I am using Win 98SE, and clean installed hla, masm32, and RadAsm in their own directories on C: drive....
Posted on 2003-08-21 13:53:00 by Damius
Hi Damius

You are probably missing nmake.exe.
Search the web and put it in C:\Hla

KetilO
Posted on 2003-08-21 14:01:48 by KetilO
OK..OK..there's too much blood in the caffiene stream this morning..;)


But once I get nmake into the hla directory I get....

NMAKE : fatal error U1073: don't know how to make 'build'
Stop.


What is happening now? :confused:

Thanks for your help everyone.
Posted on 2003-08-21 14:14:13 by Damius
Hi Damius

Guess you don't have a makefile in your project.

Here is a working hello world.

KetilO
Posted on 2003-08-21 14:38:24 by KetilO
Open makefile and change all <file> for your hla file name.
Posted on 2003-08-21 16:42:07 by Green Joe
ok..I made the changes that donkey suggested..went through the CodeBlock.txt file, and the other files in the Help directory and I still get these errors when I try to assemble a project...


Microsoft (R) Program Maintenance Utility Version 6.00.8168.0
Copyright (C) Microsoft Corp 1988-1998. All rights reserved.

NMAKE : fatal error U1073: don't know how to make 'compilerc'
Stop.

Make error(s) occured.

Microsoft (R) Program Maintenance Utility Version 6.00.8168.0
Copyright (C) Microsoft Corp 1988-1998. All rights reserved.

NMAKE : fatal error U1073: don't know how to make 'build'
Stop.

Make error(s) occured.


Seems that there is a pathing problem here...nmake cannot find what it needs to compile the source I have in the project, and I haven't figured out the pathing commands that RadAsm uses... :(
Posted on 2003-08-26 12:22:02 by Damius
Paths in RadASM are set up in the "Set Paths" selection of the "Option" menu. I'm not sure what you need, I don't use HLA but if you know where the programs are you should be able to get through it.
Posted on 2003-08-26 12:26:10 by donkey
Hi, Ketil

I am having the same problem with the makefile. Everything worked in version 2.0.9.0 but it doesn't work now (iow there were no path problems). AFAICT no changes have been made to my paths. It may be a permissions problem (on XP) since I don't usually use an administrator's group account to run RadAsm. I will attempt to run the program from an administrator's group account to see if it makes a difference. If it isn't that or if your hw project builds using nmake; I'll copy the parameters. If the hw project doesn't build, then we might have to do a bug hunt.

Thanks,

Charles
Posted on 2003-08-27 01:49:43 by cdquarles
yikes, v 2.0.2.9

Charles
Posted on 2003-08-27 01:50:52 by cdquarles
Hi, Ketil

I was able to build the hw project you supplied using a WinXP account other than an administrator's group account. Building a project with nmake will fail if: 1. no makefile (duh), 2. bad makefile sections, ie syntax errors, 3. nmake can't launch the resource compiler or the linker (path problem), and 4. nmake encounters an error condition that doesn't fit any other error message. Figuring out the last one can be difficult because the error message provides insufficient info. Modifying the hw makefile by making the relevant changes will allow it to be a template for other projects.

I am using nmake, ml, and link from Visual Studio.NET 2003 (7.10.3077.0). It is possible that version incompatibilities would cause problems also.

Charles
Posted on 2003-08-27 02:29:17 by cdquarles
In hla.ini check these sections:


1=path,c:\hla;c:\masm32\bin;
2=lib,c:\hla\hlalib
3=hlainc,c:\hla\include


;Used by PthExpl++ addin to delete minor files.
MinorFiles=*.ro.inc;*.res;*.obj;*.link;*.extpub.inc;*.data.inc;*.consts.inc;*.bss.inc;

Sets up the RadASM enviroment when a hla project is opened.
Delets temporary hla files.

KetilO
Posted on 2003-08-27 05:46:02 by KetilO
Hi, Ketil!

In my case the hla.ini lines match your post. I was able to get everything to work by using your hw project's makefile as a template. That should take care of the original poster's problems unless it falls into #4 in my list.

Thank you for your excellent program and the excellent work of your contributors.

Charles
Posted on 2003-08-27 13:50:55 by cdquarles
Is there some way to update hla.ini as to add a "compile" opton to the "make" menu that executes as follows:

hla <file.hla>

(that's it)

I'm going through the HLA 32-bit tutorial right now; not the one for windows programming, but the one for 32-bit programming under windows or linux. RadASM seems like a nice IDE and I would just assume start getting used to it. For now, all I need is simple compiling through "hla <file.hla>." I'll just keep a command window open and execute it myself if I have to... all this stuff with updating makefiles and everything is a little more than I want/need right now.

it seems like running HLA clears my doskey history somethings....very odd.

thanks
Posted on 2003-09-12 18:34:49 by mranak