WinAsmSetup1017.exe (791'320 05.09.2003).
asm-, inc-, def- and rc-file association is wrong
only wap is correct
REGEDIT4


[HKEY_CLASSES_ROOT\.asm]
@="Assembly"
[HKEY_CLASSES_ROOT\Assembly]
@="WinAsm Assembly File"
[HKEY_CLASSES_ROOT\Assembly\Shell]
[HKEY_CLASSES_ROOT\Assembly\Shell\Open]
[HKEY_CLASSES_ROOT\Assembly\Shell\Open\Command]
@="\"{app}\\WinAsm.exe\" \"%1\"" ; need @="\"C:\\WinAsm\\WinAsm.exe\" \"%1\""
[HKEY_CLASSES_ROOT\Assembly\DefaultIcon]
@="{app}\\WinAsm.exe,1" ; need @="C:\\WinAsm\\WinAsm.exe,1"

[HKEY_CLASSES_ROOT\.def]
@="Definition File"
[HKEY_CLASSES_ROOT\Definition File]
@="WinAsm Definition File"
[HKEY_CLASSES_ROOT\Definition File\Shell]
[HKEY_CLASSES_ROOT\Definition File\Shell\Open]
[HKEY_CLASSES_ROOT\Definition File\Shell\Open\Command]
@="\"{app}\\WinAsm.exe\" \"%1\"" ; need @="\"C:\\WinAsm\\WinAsm.exe\" \"%1\""
[HKEY_CLASSES_ROOT\Definition File\DefaultIcon]
@="{app}\\WinAsm.exe,4" ; need @="C:\\WinAsm\\WinAsm.exe,4"

[HKEY_CLASSES_ROOT\.inc]
@="Include"
[HKEY_CLASSES_ROOT\Include]
@="WinAsm Include File"
[HKEY_CLASSES_ROOT\Include\Shell]
[HKEY_CLASSES_ROOT\Include\Shell\Open]
[HKEY_CLASSES_ROOT\Include\Shell\Open\Command]
@="\"{app}\\WinAsm.exe\" \"%1\"" ; need @="\"C:\\WinAsm\\WinAsm.exe\" \"%1\""
[HKEY_CLASSES_ROOT\Include\DefaultIcon]
@="{app}\\WinAsm.exe,2" ; need @="C:\\WinAsm\\WinAsm.exe,2"

[HKEY_CLASSES_ROOT\.rc]
@="ResourceScript"
[HKEY_CLASSES_ROOT\ResourceScript]
@="WinAsm Resource Script"
[HKEY_CLASSES_ROOT\ResourceScript\Shell]
[HKEY_CLASSES_ROOT\ResourceScript\Shell\Open]
[HKEY_CLASSES_ROOT\ResourceScript\Shell\Open\Command]
@="\"{app}\\WinAsm.exe\" \"%1\"" ; need @="\"C:\\WinAsm\\WinAsm.exe\" \"%1\""
[HKEY_CLASSES_ROOT\ResourceScript\DefaultIcon]
@="{app}\\WinAsm.exe,3" ; need @="C:\\WinAsm\\WinAsm.exe,3"

[HKEY_CLASSES_ROOT\.wap]
@="WinAsm Project File"
[HKEY_CLASSES_ROOT\WinAsm Project File]
@="WinAsm Project File"
[HKEY_CLASSES_ROOT\WinAsm Project File\Shell]
[HKEY_CLASSES_ROOT\WinAsm Project File\Shell\Open]
[HKEY_CLASSES_ROOT\WinAsm Project File\Shell\Open\Command]
@="\"C:\\WinAsm\\WinAsm.exe\" \"%1\""
[HKEY_CLASSES_ROOT\WinAsm Project File\DefaultIcon]
@="C:\\WinAsm\\WinAsm.exe,0"
PS test w2ksp4 and w98se
Posted on 2003-09-15 02:23:29 by P2M
Thanks P2M for pointing this out!

Masmer are you reading please ?

Regards,

akyprian
Posted on 2003-09-15 02:55:43 by akyprian
Try this plugin.
Posted on 2003-09-15 04:15:12 by Bi_Dark
Thanks Bi_Dark,

Very useful one!

Regards,

akyprian
Posted on 2003-09-15 04:17:01 by akyprian
Argh. I had everything working earlier (I think) when WinAsm didn't support external files so I exported the settings in case I would need them someday. It appears importing them back into Inno didn't work or they never worked ... sorry for not completely testing this.

I'll update the installer with the proper file associations (unless Bi_Dark's add-in allows selection of file associations!) and with the (AddProc, UPX, WinErr and hopefully Melt) add-ins by this next weekend.

Can I include your add-in in the installer Bi_Dark?
Posted on 2003-09-15 06:58:48 by Masmer
Of coz, you can do whatever you want!
Posted on 2003-09-15 07:23:58 by Bi_Dark