yesterday I tried to install a hard drive into the primary slave IDE cable, and then the system could not see the master hard drive, so I removed the slave hard drive, and the system now does not boot up anymore.

what can be the problem ?
Posted on 2003-10-20 12:24:20 by maCo
in BIOS -> CMOS Settings , set the 2 HDDs to be automatically-detected on each run, "Auto" instead of "User" . Or you can set them with "Auto detect IDE ..." .
Posted on 2003-10-20 16:23:05 by Ultrano
Two things to check, first if you are using a Compaq, make sure that your IDE cable is flat without a twist in it as there are some that use cable select. This will result in your primary drive not being recognized but the slave being seen. Second be sure to properly orient the cable the red strip should be on the pin 1 side of the connector, usually indicated by the number 1 or a square solder pad. If you have reversed the pins then started your PC you may have to format your drive as it may have damaged your boot sector.
Posted on 2003-10-20 16:35:27 by donkey
Hi
yeah the settings are on AUTO.
I dont know what is the problem but now the system does not boot up.
I left it the way it was before, it is a HD with two OS, so it had a dual boot up, now it does not asks me what OS I want to load up.
maybe the MBR got overwritten or something, I think I will have to install everything back again :(
It is a HP Pavilion 8756C

Thanks
Posted on 2003-10-21 10:53:40 by maCo
Been a while since I've been in the low level trenches of HD's ;)

Before you throw in the towel do some more info gathering. Im assuming your wire in correctly as Donkey suggested.

Get a boot disk from another CPU and boot your problem CPU off it. Ensure you have fdisk on it as well.

When you stick in your boot disk and start up, see if any info at all is given from your hard drive (origional master) from the bios screen.

When you get to a command prompt, type FDISK and Yes for large disk support.

Choose the VIEW option (think its item 4 on the list) and view your master partition. See if its still the primary. It should say PRI_DOS with a status level "A" for Active.

If its there but no "A" then you will need to reset it as active. Do so by the main menu option 2 (set active partition). This operation is safe and should not require any reformating of your drive. (If it somehow lost the active status from the drive).



Beyond this I have not much to suggest. Did you set up your dual boot and drive structure with Partition Magic?? (I hope not). I've heard horror stories from people who trusted this product implicitly and latter realized the magic is more like smoke and mirrors. As well what is your message when you try to boot from the hard drive.. Do you even get a message??

Hope some of this is a help to you. Dont format untill your 100% sure you've done all you can! And ask questions about FDISK if your not sure of it. You can *really* screw things up more if your not familiar with this!!! Worst case I can think of is your IDE port on your mother board is ka-put. Not your hard drive. (Oh ya, does the problem drive even 'grunt' when you power up the CPU? This might be a big clue!) . If deseparite you can take the HD to another computer's IDE bus and check it out via. BIOS as well.

If you want our thoughts, the more info on what is happening the better for this kinda problem. Even the little details like "yes it grunted on startup" ;)

:NaN:
Posted on 2003-10-21 21:29:53 by NaN
Have you ensured that the jumpers on the hd's are set correctly for master and slave? Also, ensure that you follow ultrano's suggestion on bios settings. Although I've had problems with larger hd's using the 'auto' setting. I don't recall exactly, but I think it was drives larger than 40gb that caused the 'auto' issue. I'm not sure if newer systems have that problem though.


cheers,
will
Posted on 2003-10-22 09:23:32 by Will
to restore a windows MBR call up a dos prompt and do fdisk /MBR
Posted on 2003-10-22 10:28:42 by Hiroshimator
Hi
when the computer stars, it does one normal beep, and no error message is shown, just "_"
the first partition of the master hd is set as active.
the dual boot was set by windows when I installed the second OS in the second partition.
I have also tried fdisk /mbr twice and same problem.

so I backed up the hd and then formarted the hd, now everything works ok :P.
thank you all
Posted on 2003-10-23 14:27:09 by maCo