Hi,
I'm facing some problem, anyone can help?
- In Project.C-- file line 266 the GetProc procedure not functioning
- In Project.C-- file line 205 if I delete "//" the C--IDE shut down immediately if I open the project file (*.CMP)
- In FileIORA.C-- file line 67, if I move the GetProc up one line (above SendMessage(hREd, REM_SETBLOCK,0,#blocks)), the GetProc not functioning.:confused:

Is this the Sphinx C-- problem or RAEdit problem (REM_NXTBOOKMARK at Property.C--)

Thanks
Posted on 2003-11-01 08:11:19 by QS_Ong

Hi,
I'm facing some problem, anyone can help?
- In Project.C-- file line 266 the GetProc procedure not functioning
- In Project.C-- file line 205 if I delete "//" the C--IDE shut down immediately if I open the project file (*.CMP)
- In FileIORA.C-- file line 67, if I move the GetProc up one line (above SendMessage(hREd, REM_SETBLOCK,0,#blocks)), the GetProc not functioning.:confused:

Is this the Sphinx C-- problem or RAEdit problem (REM_NXTBOOKMARK at Property.C--)

Thanks

This problem You three. :)
There is documentation on RaEdit?
Posted on 2003-11-03 03:42:31 by Sphinx
Line 262: ecx modified by api
Posted on 2003-11-03 06:38:53 by roticv
Hi roticv,
May I know what debugger you use? Source debugger? And how to know ecx is modified by API?

Thanks.
Posted on 2003-11-03 08:13:17 by QS_Ong
My mistake.. I thought that ecx was used as a loop counter. Seems like I was wrong. Anyway I just examined the code, have yet to play with the debuggger. Anyway I do not use source-debugger, a normal debugger would do fine with me.

I think the problem lies in the "GetProc"
Posted on 2003-11-03 09:36:55 by roticv


I think the problem lies in the "GetProc"


This function not there is reason of these problems. I its has checked. There, there is bad fragment, but they do not influence upon work.
I seem the problem in stack or local variable. Program behaves is distinguished on miscellaneous operating systems (Win98/WinMe).
Posted on 2003-11-03 23:20:45 by Sphinx
Hi,
When I open a project, some of the function list in property window when click cannot point to function itself. :mad:
Anyone can help.;)

Regards.
Posted on 2003-11-05 08:04:26 by QS_Ong
Forgot the attachment. :grin:
Posted on 2003-11-05 08:05:22 by QS_Ong
I can see it eating up to 99% of my cpu. Is WM_PAINT handled properly?
Posted on 2003-11-05 08:17:42 by roticv
Hi roticv,

I can see it eating up to 99% of my cpu. Is WM_PAINT handled properly?

It works OK in my Cwin98se and Win 2k server sp1.:confused:
Try to unzip it to an empty folder and run it again.

Regards.
Posted on 2003-11-06 08:01:49 by QS_Ong
Weird, now the problem is gone. hmm.
Posted on 2003-11-06 08:12:26 by roticv
Hi,
- Open C--IDE
- right click project window and open C--IDE.CMP
- click on property window one by one
from AddFile to CallSearch to CloseProject ... up to CreateRAEdit,
error on clicking at CreateRAEdit
- sometimes click at property windows don't go to the actual function. :confused:

Please help. :)

Thanks
Posted on 2003-11-10 08:14:55 by QS_Ong
If before calling EM_GETLINE type
nLength = SendMessage(hList,EM_GETLINE,nLine,#line);
File PROPERTY.C-- line 11 and 170, file PROJECT.C-- line 273
add the string:
SSWORD[#line]=256;
That program work better.
:alright:
Posted on 2003-11-11 04:02:59 by Sphinx
QS_Ong: wow, nice stuph :alright:
I see that I am on the credits - is this related to the CiDE ? :)

sorry that I dont have time to take a good look on the code,
but I will hope to have it soon.

keep up the good work and feel free to use anything from CiDE.
Posted on 2003-11-13 06:49:15 by TBD
Hi TBD
Originally posted by TBD

keep up the good work and feel free to use anything from CiDE.

Thanks TBD, I copy some code from your CiDE and implement it in C--IDE.

Finally the property window work OK :cool:
But old bug gone, new bug come. :mad:
- Double click on Project window can open the same file again.:mad:
- Open the same file name (with different content, eg file in different folder) sometimes confuse the IDE and mixed up the content. :confused:

Anyone can help :)

Thanks
Posted on 2003-11-14 08:19:10 by QS_Ong
Hi,
In C--IDE, open a C-- file, open a project (eg C--IDE.CMP), click on property window, press F6 to refresh it, the property window show double function. :mad:

If I don't click on property window, the refresh function work OK.:confused:

Anyone can help? :)
Posted on 2003-11-16 01:35:52 by QS_Ong
Hi,
Open test.C--, only one proc I can't solve (Cannot display in property window), the problem might be in GetProc(). :confused:

Anyone can help. :)
Posted on 2003-11-20 08:19:49 by QS_Ong
Hi,
Finally it works.:cool:
Attach here with serious bug fixed C--IDE.

Any bug please report .

Thanks
Posted on 2003-11-21 08:47:35 by QS_Ong
QS_Ong:

1. open C--IDE.CMP
2. click on "AddFile" in property window
3. click on down arrow in source window (it will disappear)
4. click on "Close Project" in property window
5. click on "AddFile" in property window again - it will not jump to the code in source window
Posted on 2003-11-25 01:34:55 by TBD
Hi,
Thank TBD, try this one.

Fix bug in File Save As, Ctrl+S, right click on project window prevent adding file if no project create (it will confuse IDE if adding file without creating project)

In Output.c--, line 17 SendMessage(hOut,EM_GETLINE,EAX,#line) return zero :confused:
Anyone can help :cool:

Thanks
Posted on 2003-11-27 07:46:30 by QS_Ong