After applying a point light in front of the scene some distant objects became choppy on my GeForce.
Why should it be? Please Help. Light position doesn't matter.
Posted on 2003-11-13 07:45:07 by Vaxon
Turn texture filtering on :)
You are experiencing moire patterns.

Try enabling bilinear filtering !!
Posted on 2003-11-13 07:54:15 by Homer
I turned filtering on, but nothing. Btw those white planes have no textures at all...
Posted on 2003-11-13 07:56:01 by Vaxon
Looks like it was because i set the culling mode to D3DCULL_NONE.
Works fine now.
Thanks.
Posted on 2003-11-13 08:09:47 by Vaxon
So overdraw was creating that effect? I assume that you have Alpha enabled then, I'm glad to see you fixed it by enabling backface culling. Have you since taken a look at your cockpits close up?
If you find that your backface culling looks silly inside the cockpit when viewed from outside it, I recommend you make two render passes for your alpha and non-alpha textures, and enable backface culling when rendering non-alpha textures, so that we get nice portal views through translucent surfaces...
Keep up the good work !!
Posted on 2003-11-16 00:26:33 by Homer
Yes, it was overdraw and I had alpha enabled. Gonna take a closer look at the cockpit now. Thanks for the suggestion :)
Posted on 2003-11-17 06:47:36 by Vaxon