KetilO,

You're right... MASM 6.15 does remove the problems I've been complaining about and MASM 7.x actually are the reasons for the problem, it doesn't accept wildcards on the command line...



Thanks,
_Shawn
Posted on 2001-11-01 13:27:34 by _Shawn
I'm impressed.
Posted on 2001-11-02 13:09:04 by sp0nge
Forgive me if somebody has already mentioned this. I don't really feel like reading the entire post ;).

When I select many lines to comment via F10, it may or may not comment the last line. Seemingly only when I don't want the last line commented, it does, and when I do want it commented, it won't. As Caleb said, user-defined shortcuts would be nice. But please don't take offense, I would never knock my most favorite editor ever!
Posted on 2001-11-03 12:28:00 by lackluster
Hi lackluster

If you only partialy include the last line in the selection, the last line will not be commented / uncommented. Tjis is a bug I will look into.
User-defined shortcuts are on my long wishing list. Just give me some time.

KetilO
Posted on 2001-11-03 12:38:05 by KetilO
Hi KetilO:
I used RadASM for two days and everything worked very well, then all of a sudden I can no longer view the output window. I had already updated the ASCII dll, so I don't think that is the problem. I tried activating from both the toolbar and menu using the mouse and hotkeys. I checked and played around with tool clipping settings in the ini file but no happy result.
In addition I re-extracted the radasm.exe file and copied over the existing file, still no output window to be found.
The only other thing that was unusual was that I inadvertently exited the program using Alt-F4 and I believe, but am not 100% sure, the problem started after that.
I very much liked the interface you have developed and hope you can help me with my problem.
I am using W98SE.
Regards
Fumio
Posted on 2001-11-08 17:12:53 by Fumio
Hi Fumio

I would expect there is an error in RadASM.ini
Try to extract the file and paste the section into
your RadASM.ini file.

KetilO
Posted on 2001-11-08 18:05:25 by KetilO
Hi!

Could someone please explain this. I have a program with a dialog as main. I use RadAsm. I compile and the dialog shows up just as designed. I now add a progressbar to the dialog. I recompile the RC. When I give the Go command, the program compiles nicely, but the dialog doesn't show up. Why is this? The same thing happens when I try to use a RichEdit.
What am I missing here?

Sorry! I was missing the invoke InitCommonControls!:grin:
Posted on 2001-11-08 18:15:07 by Storck
Hi Storck

In order to use progress bar you must init common controls:

invoke InitCommonControls

To use month view and date picker:

.data?
iccex INITCOMMONCONTROLSEX <?>

.code
.
.
mov iccex.dwSize,sizeof INITCOMMONCONTROLSEX
mov iccex.dwICC,ICC_DATE_CLASSES
invoke InitCommonControlsEx,addr iccex

And RichEdit:

.data
RichEditDLL db 'riched20.dll',0

.code
.
.
invoke LoadLibrary,addr RichEditDLL
mov hRichEdDLL,eax

Thats it.

KetilO
Posted on 2001-11-08 18:45:31 by KetilO
Hi KetilO:
Yes, thanks, that fixed it. When I compared the original ini against the existing file it was clear what the problem was but that brings up the question what would have caused that to happen?

In any event I am pleased that 'Rad' is working for me again.
Regards
Fumio
Posted on 2001-11-08 19:00:21 by Fumio
Heya KetilO,

First of all, I think RadASM rocks... I dumped Ultra-Edit for it -
which is quite remarkable...

Here's some improvement I would definitively appreciate:

1) When I add something to the Tools Menu - I'd love to have an
option which would turn it into a Button on the ToolBar. (I am
that lazy - yes... /me blushes )

2) When I hit the GO/Compile Button, I loose all the Undo
History.. Is there a way preventing this?

That's it... No, complains :tongue:

Keep up the good work.

JimmyClif
Posted on 2001-11-10 15:34:03 by JimmyClif
Hi JimmyClif

1. Adding a toolbar button is a good idea. I will find a way to do this. You know you can do this in an addin.

2. I am surprised no one complained about this before. There should be no reason to clear undo buffer when saveing. I will find out why this happends.

KetilO
Posted on 2001-11-10 16:19:05 by KetilO