Hi WillAsm,

If you open an asm file without a project then build the asm file using the MakeDefNoProject feature, you will get 5 blank message boxes with "RadAsm version 2.0.3.7" in the caption. This is definitely Version Control as it does not happen unless that addin is loaded.

OT: Did you go to the game ? I would have given anything to be there :)
Posted on 2003-11-24 10:34:32 by donkey

Hi WillAsm,

If you open an asm file without a project then build the asm file using the MakeDefNoProject feature, you will get 5 blank message boxes with "RadAsm version 2.0.3.7" in the caption. This is definitely Version Control as it does not happen unless that addin is loaded.

OT: Did you go to the game ? I would have given anything to be there :)


I have tried to duplicate this without success. Can you send me a copy of an
asm file that causes this so I can test it here? The message box is coming from
RadASM, it may very well be my addin is the cause, but I also suspect it may be
an out of date RadASM ini file.. Anyhow, if you an send any asm file which causes
this effect, then I'll try to track it down...

By the way, you should have been there! Cold as all h*ll, but well worth it!
It has been a lot of years since I have seen all of them to on the ice together! :grin:

WillASM
Posted on 2003-11-24 11:07:17 by WillASM
Hi WillAsm,

Create a new folder then copy any asm file to it then open it in Radasm. Disable then enable the Version Control addin then use Build to build the exe. You will see the dialogs.

OT: I watched the game on TV (at least the old timers) and yes I would have liked to have been there. It was like -21 with the wind but I know how to dress warmly and for a chance to see Gretz and the gang not to mention Guy Lafleur it would have been worth it.
Posted on 2003-11-24 11:19:21 by donkey
Tried it on several of the examples from the masm32 package and still cannot
re-produce this bug. Can you do me a favour? Rename your masm.ini file & try
the one in the iniFiles.zip I still suspect it may be a problem with the ini file..?

WillASM
Posted on 2003-11-24 12:12:06 by WillASM
Hi WillAsm,

no luck, with the zipped ini files the result is the same and consistent. I replaced MASM.INI and RadASM.ini.
Posted on 2003-11-24 12:20:49 by donkey
Thanks for trying, Donkey.

This is really starting to bug me! Do you have the most recent ini files?
I really would like to track this down now, as I was planning to add a
couple of minor changes to the addin anyways. So finding any bugs now
is a priority... I'll keep trying to track this down today.

WillASM
Posted on 2003-11-24 12:37:36 by WillASM
Hi Will,

I unzipped the INI files from the most recent distro of RadASM. I can make this happen consistently so it is definitely Version Control. I am running Win2K SP4 I will try later on my Win98SE machine.
Posted on 2003-11-24 12:48:30 by donkey
Thanks Donkey, and yes please try under 98. I use win98se and am not seeing
this bug. That may be where the problem is...

WillASM
Posted on 2003-11-24 12:59:43 by WillASM
Hi WillASM

It does not happend on Win98SE.

KetilO
Posted on 2003-11-24 13:08:44 by KetilO
Yup, I can confirm that. I could not duplicate the problem on Win98SE.
Posted on 2003-11-24 13:12:27 by donkey
Ok, thanks guys.. Probably not preserving regs somewhere. Should be no
problem to fix...

WillASM
Posted on 2003-11-24 15:21:20 by WillASM
KetilO and Donkey were right. Once I disabled version control add-in in radasm.ini the blank popups stopped. Thanks guys!
Posted on 2003-11-24 22:46:10 by xkardisx
Hi Ketil,

You forgot to include the CodeBlock for nasm:


1=istruc $,iend,,,6
2=%macro $,%endmacro,,,14
3=[SECTION,,,,16
4=segment,,,,16
Posted on 2003-11-24 22:56:48 by donkey
Templates finally working 100% ...

but somehow the template files are copied into my projectfolder aswell.

Example:


I created [b]Personal.tpl[/b] template ( containing the modified files of [b]DialogAsMain.tpl[/b] )
I create a new project called MyProgram using [b]Personal.tpl[/b]
The [color=red]MyProgram.asm [/color] files are then stored together with the [color=red]Personal.asm[/color] files...



Then i have to manually delete them again. (the Personal.asm files)
There are empty lines in the Radasm MainProject files dialog aswell.

Is this a new feature ??

regards
Ranma
This message was written entirely in my Messageboard Editor v4.0
Posted on 2003-11-26 03:52:28 by Ranma_at
Hi Ranma_at

When creating the template, do not add any files that are alredy in the project.
You can manually edit your template file and remove these files or you can just create a new template.

KetilO
Posted on 2003-11-26 04:32:12 by KetilO
GPF sometimes while typing after invoke.
Posted on 2003-12-01 00:04:05 by The Svin
In RaEdit module, sometimes (sometimes too often), only after pushing ENTER. Check out the image...
Posted on 2003-12-01 17:10:57 by Milos
Yup, I had it happen here twice, didn't send it to the JIT though, hit OK too fast :) But both times it happened after I had selected a block of text and deleted it with backspace, moved the cursor and pressed enter.
Posted on 2003-12-01 18:52:59 by donkey
Hi The Svin

Was able to get this GPF once but needs a little time to find what causes it.

KetilO
Posted on 2003-12-02 07:57:19 by KetilO
Hi Milos / Donkey

The bug is in the auto indent function. Will you try if this helps?

KetilO
Posted on 2003-12-02 07:59:20 by KetilO