Hi all,

I've got some strange behaviours with Radasm:

Radasm v 2.0.3.7 (fresh install)
OS: Win 2000
Assembler: MASM32 v8

Here's what i'm doing:

- File > New Project
- Win32 APP
- I give a project name & description
- I choose DialogAsMain.tpl as template
- Next (2 times)

And i got a crash: Instruction at "0x77e0006f" use memory address "0x70742edd". Memory can't be written

First of all: It's only crashing with this template, i've tryed the others and they are working.

I've tryed to debug Radasm to see where it could came from. Those addresses are located in USER32.dll. But in fact i haven't seen a wrong code in Radasm.

The problem occurs at 0x42E7DE after the LEAVE instruction, top of stack became 0x77e0006F, but this address is some garbage code in USER32.dll (i think this address is "beetween" two legal opcodes, i mean it's falling in the middle of an instruction).

Don't know hot to fix it (not using this template :) ).

I hope someone could tell me what's going wrong, and if i can do something...
Posted on 2003-12-13 12:49:25 by Neitsa
Hi Neitsa

I have had other complaints about this template. I will try to find out what's wrong with it.

KetilO
Posted on 2003-12-15 04:34:23 by KetilO
I got the crash too, I'm using Windows ME and my system crash, but this bug don't happen in Windows XP.
Posted on 2003-12-22 08:31:17 by neverending
Hi neverending,

I believe the template problem has been fixed. Download 2.0.3.8 and try that, be sure to also download the retrograde patch at the top of this forum so that you are not affected by the current bug.
Posted on 2003-12-22 10:38:53 by donkey
Hi all
Im having the same type of problem with release 2.0.3.8. But the crash occures on all templates. Works ok as long as no templates.

Using Win2k.
Anyone found out a work around?

Thanks


I had RadAsm in D:\Programming\Assembly\Asm Editors\RadASM
All templates crashed except Game.tpl
Copied RasAsm from above folder to D:\Programming
All templates work ok.
Hmm curious.
Copied RasAsm to D:\Programming\Assembly\Asm Editors\RadASM\test1\test2\test3
All templates crash.
So theres seems to be a string or path problem somewhere.
Posted on 2004-01-18 05:51:29 by packetvb
Thanks a lot packetvb,

Yes, your hint solved the problem for me either. It works great now. (V 2.0.3.8 has the same problem)

My Radasm was deep in a path and i moved it to the root of my partition (eg: D:\Radasm) and it works now !!!

Maybe it's a win ME/2000 problem cause it doesn't seems to happen on XP.

Maybe Ketilo should take a look at this or put a note on the Readme.txt that comes with the Radasm Package.

Anyway, Radasm is great !!!

Thanks you very much. Regards, Neitsa.
Posted on 2004-01-30 09:31:20 by Neitsa
I don't use templates but maybe it doesn't like spaces in the path name?

Neitsa, did your path contains any spaces?
Posted on 2004-02-01 01:30:03 by Maelstrom
Hi Maelstrom,

No, my previous Path wasn't containing any spaces, but was very long (deep in my tree directory).

I moved it now to my root directory:

D:\Radasm 2.0.3.8

It contains a space now but it works great. But maybe you point something important Maelstrom. I think, in fact,
that the problem is due to long path and not to spaces in path name...

Anyway, thanks to the Win32Asm community !

:alright:

Regards, Neitsa.
Posted on 2004-02-03 17:19:00 by Neitsa
Hi all

The problem was related to long paths. A bugfix (2.0.3.8c) has been uploaded to my website.

KetilO
Posted on 2004-02-04 01:59:49 by KetilO