I have moodified the Dll2Lib program for creating impoort libs
compatible with Polink.exe. The generated libs work fine, but when
I try to combine them into one like so

lib /out winbasep.lib *.lib (polib gives same result)

the generated file winbasep.lib does'nt work. I keep getting the
the same errors error when linking:

POLINK: error: Symbol 'winbasep:.idata$2' is multiply defined.


Does anyone have any explanations/suggestions
Posted on 2003-12-24 10:33:09 by gfalen
Hi gfalen,

I guess you are trying to create an import library like Borland's import32.lib. Are you sure that you can build the same type of library for MS COFF format?
Posted on 2003-12-24 12:01:56 by Vortex
Hi vortex. Yes I have created winbase.lib using the standard libs from masm32 (sdk libs work too)

lib /out:winbase.lib gdi32.lib kernel32.lib user32.lib ...

This greatly simplifies things.
Posted on 2003-12-24 12:12:50 by gfalen
Hi gfalen,

I got also the same error message with polink. I tried to merge the libs with MS Link,it worked.:)
Please try my tool dll2lib V1.01 (the previous version)
I will work on the problem with polink.
Posted on 2003-12-24 12:46:11 by Vortex
Your winbase.lib does'nt work on my system with either linker. What commnd line did you use to make it?
Posted on 2003-12-24 12:55:34 by gfalen
Hi gfalen,

Try to link your object file with MS Link istead of Polink (+ winbase.lib), it works. Please check the attachment.
Run the batch file buildlib.bat to create the library.

My import lib was created on a win95b system.
Posted on 2003-12-25 05:34:58 by Vortex