Hello,

I'm trying to compile my Dll but it's not working. It's strange because my older Dll projects are working well. I've reinstalled Radasm in his last version but it's always the same thing.

I wasn't sure about the error, so i've done a Dll project with the example from Iczelion.

Here's the output when i'm pushing the "Buil" button:



Assembling: info.asm

Make error(s) occured.
ERROR On Build: Version Number Was Not Increased.


If i try only a link, here's what i got:



LINK : warning LNK4001: no object files specified; libraries used
LINK : warning LNK4068: /MACHINE not specified; defaulting to IX86
LINK : fatal error LNK1104: cannot open file "info.def*.asm"
LINK : fatal error LNK1141: failure during build of exports file

Make error(s) occured.


I don't know where the error came from.

Thank you very much.

Regards,Neitsa.

I attach this little project.
Posted on 2004-04-05 12:39:26 by Neitsa
Hi Neitsa

There seem to be some garbage added to the projects main filenames.
Use Project / Main Project Files and remove the garbage.

KetilO
Posted on 2004-04-05 15:05:51 by KetilO
Thank you very much Ketilo !

Removed trash on file name's and it works.

But each time I'm doing a new Dll project, there's this junk on file name's. (everything is fine with Exe files).

I've tried with a fresh install and redownloaded the package on the site and it's always the same thing...Sounds strange.

OS: Win 2000 SP4
Radasm : v2.0.4.2

Thak you very much !

Regards, Neitsa.
Posted on 2004-04-05 16:52:43 by Neitsa
Hi Neitsa,

I am also running Win2K SP4 and have no such problems. Are you using a template for your DLL project ? If so zip your RadASM.ini, assembler.ini file and the tpl file you are using and post them so they can be analyzed. It is obviously a problem with either masm.ini (or the assembler.ini file for your assembler) or your template file.
Posted on 2004-04-05 16:58:39 by donkey
Hello,

This morning I've tried again. Here's what I'm doing:

-Fresh install (I've downloaded again the package from Ketilo's web site)
-Immediatly starting a DLL project
-No template at all (Starting from blank file).
-Nothing touched during the configuration project (only entered a name and a descpription)
- Copy/paste from Iczelion tut (the code isn't the problem)


And finally always the same error message (see first post).

I've got garbage in name's file (in the main Project files; My files on my HDD are ok!):

project named: info

- .rap .rc .asm are ok
- .obj has some problem: info.obj/I"$I",*.asm <= looks like it's the string for command line !?
- .res: info.res$I",*.asm
- .exe : info.exe,*.asm
- .def : info.def*.asm
- .dll : info.dll.asm
- .txt : it's ok
- .lib: info.lib",*.asm
- .mak : info.mak,*.asm
- .hla: info.hla*.asm
- .com : info.com.asm



What is strang it's the fact that even with a fresh install, the problem is always here...

If you want more details I'll be glad to help you.

Thank you very much.

Regards, Neitsa.
Posted on 2004-04-06 09:12:41 by Neitsa
I'm not really interested in your RAP file, the MASM.INI and RADASM.INI files are of much more interest. Both from your old folder and the fresh install. These are my masm.ini and radasm.ini files, they are known to be good for the current version. I have tried to create a dll and had no problems at all with it, try replacing the two files.

For others, my ini files for masm are the same as yours so don't bother downloading them.
Posted on 2004-04-06 14:11:35 by donkey