I hope to use RasGetEntryDialParams in my code but I cant get a
RASDIALPARAMS structure to work.
____________________
.DATA?
Dial_Params RASDIALPARAMS ?
-------------------------------

that wont work for me :-(

how do i define it?

any example code would be nice.

thanks
Posted on 2001-11-08 22:31:15 by robsonde
Try this:

.DATA?
Dial_Params RASDIALPARAMS { }
Posted on 2001-11-09 00:10:21 by Irving W.
well I tryed it and now i get "error A2008: syntax error : Dial_params"
Posted on 2001-11-09 01:14:20 by robsonde
Hi,
it seems the problem is the size of the structure.

dw_Size parameter of the RASDIALPARAMS structure is 041Ch, not 0419h !
dw_Size parameter of the RASENTRYNAME structure is 0108h, not 0105h !
dw_Size parameter of the RASCONN structure is 019Ch, not 019Bh !
dw_Size parameter of the RASCONNSTATUS structure is 00A0h, not 009Eh !


bye TD
Posted on 2001-11-09 02:45:02 by Test Department
TD, that may be true, but it doesn't explain the syntax error.

It looks like a problem with the way it's defined in WINDOWS.INC.

RASDIALPARAMS is EQUated to RASDIALPARAMSA, which is the actual STRUCT. It assembles OK if you use the A version:

Dial_Params RASDIALPARAMSA {}

There are several STRUCTs EQUated this way in WINDOWS.INC, and I would think they would all produce the error.

Maybe hutch or Icz can comment on this???

:confused:
Posted on 2001-11-09 02:55:32 by S/390
OK, here's the real problem, at least with the syntax. The EQU is incorrect in WINDOWS.INC. It is missing the <> (or {}).

RASDIALPARAMS EQU RASDIALPARAMSA

I changed it to

RASDIALPARAMS EQU <RASDIALPARAMSA>

and it works fine.

Again, there are several EQUs that seem to have this same error.

:(
Posted on 2001-11-09 03:16:03 by S/390
and now it works!

thank for the help all!
Posted on 2001-11-09 03:22:06 by robsonde