Hi Ulterior

First of all. There was a bug in RadASM when assembling modules in debug mode.
You can get the bugfix here
One good reason to use modules is to save build time on large projects.

As stated earlier RadASM is very flexible and can in most cases be set up to behave the way you prefere.

Assemble modules along with main project:

1. Open masm.ini
2. Find section
3. Change:
2=&Assemble,31,M,2
To:
2=&Assemble,31,M,6,2
And:
4=&Build,103,M,2,3
To:
4=&Build,103,M,6,2,3
And:
6=&Go,43,M,2,3,4
To:
6=&Go,43,M,6,2,3,4
And:
11=Go &All,79,M,1,2,3,4
To:
11=Go &All,79,M,6,1,2,3,4

To assemble open and topmost module file:
1. Open masm.ini
2. Find section
3. Add:
14=Assemble open Module,0,M,5
And change project build option:
Res To Obj: 0,OT,$B\ML.EXE /c /coff /Cp /nologo /I"$I",$.asm

To disable module build time check:

Option / Really Rad / Goto code / Check module buildtime.

KetilO
Posted on 2004-05-17 04:04:07 by KetilO
I have downloaded 2.0.4.2 fix i - and haven't noticed any difference betwean release/debug module builds. Size is the same

In debug mode, radasm simply prints 2 lines

Assembling: Mod\Module2.asm
Assembling: Mod\Module1.asm

In release version:

C:\Masm32\Bin\ML.EXE /c /coff /Cp /nologo /I"C:\Masm32\Include" "Mod\Module2.asm"
Assembling: Mod\Module2.asm
C:\Masm32\Bin\ML.EXE /c /coff /Cp /nologo /I"C:\Masm32\Include" "Mod\Module1.asm"
Assembling: Mod\Module1.asm

Make finished.
Posted on 2004-05-17 04:26:17 by Ulterior
If you specify OT instead of just O in build options you will see the actual command line.

Note that the RadASMini.rtf file documents the RadASM ini and project files.

KetilO
Posted on 2004-05-17 04:35:44 by KetilO
Thanks, Ketil for help,

I think this topic is closed for me now.
Posted on 2004-05-17 04:45:49 by Ulterior