Hey KeltIO,

Im working privately with someone and we are both using RadAsm v2.0.4.2 (at the time we decided to use this we found v2.0.4.3 had more evolving to do).

That said, the 4.2 version works greate, but when we share projects in zip format and recompile on either end, It will often run the Make RC after every operation. Even RUN will initiate another rebuild of the RES file!! I dont understand where this extra behavior is comming from. Is this a set up problem, or something else?

Regards,
:NaN:
Posted on 2004-06-13 13:29:44 by NaN
For example, the following is an output from a "Compile RC" option, chosen from the MAKE toolbar option:
Microsoft (R) Windows (R) Resource Compiler, Version 5.00.1823.1 - Build 1823


Copyright (C) Microsoft Corp. 1985-1998. All rights reserved.


Using codepage 1252 as default
Creating Demo15.RES

RC: RCPP -CP 1252 -f E:\masm32\ObjAsm32\Examples\Demo15\RCa03600 -g E:\masm32\ObjAsm32\Examples\Demo15\RDa03600 -DRC_INVOKED -D_WIN32 -pc\:/ -E -I. -I .

Demo15.rc.
Writing ICON:1, lang:0x0, size 1384
Writing GROUP_ICON:ICON_APP_16, lang:0x0, size 20.
Writing ICON:2, lang:0x0, size 2216
Writing GROUP_ICON:ICON_APP_32, lang:0x0, size 20.
Writing ICON:3, lang:0x0, size 296
Writing GROUP_ICON:ICON_GIFT, lang:0x0, size 20.
Writing ICON:4, lang:0x0, size 296
Writing GROUP_ICON:ICON_OPEN, lang:0x0, size 20.
Writing ICON:5, lang:0x0, size 1384
Writing GROUP_ICON:ICON_NEW, lang:0x0, size 20.
Writing ICON:6, lang:0x0, size 296
Writing GROUP_ICON:ICON_SAVE, lang:0x0, size 20.
Writing ICON:7, lang:0x0, size 296
Writing GROUP_ICON:ICON_SAVEAS, lang:0x0, size 20.
Writing ICON:8, lang:0x0, size 1384
Writing GROUP_ICON:ICON_CUT, lang:0x0, size 20.
Writing ICON:9, lang:0x0, size 1384
Writing GROUP_ICON:ICON_COPY, lang:0x0, size 20.
Writing ICON:10, lang:0x0, size 1384
Writing GROUP_ICON:ICON_PASTE, lang:0x0, size 20.
Writing BITMAP:BMP_BACKGROUND, lang:0x0, size 6504.
Writing DIALOG:DIALOGABOUT, lang:0x0, size 198.
Writing DIALOG:DIALOG1, lang:0x0, size 406.
Writing MENU:MENU_APP, lang:0x0, size 184.
Writing STRING:4, lang:0x0, size 114
Writing STRING:63, lang:0x0, size 94
Microsoft (R) Windows (R) Resource Compiler, Version 5.00.1823.1 - Build 1823

[color=red]Copyright (C) Microsoft Corp. 1985-1998. All rights reserved.


Using codepage 1252 as default
Creating Demo15.RES

RC: RCPP -CP 1252 -f E:\masm32\ObjAsm32\Examples\Demo15\RCa03424 -g E:\masm32\ObjAsm32\Examples\Demo15\RDa03424 -DRC_INVOKED -D_WIN32 -pc\:/ -E -I. -I .

Demo15.rc.
Writing ICON:1, lang:0x0, size 1384
Writing GROUP_ICON:ICON_APP_16, lang:0x0, size 20.
Writing ICON:2, lang:0x0, size 2216
Writing GROUP_ICON:ICON_APP_32, lang:0x0, size 20.
Writing ICON:3, lang:0x0, size 296
Writing GROUP_ICON:ICON_GIFT, lang:0x0, size 20.
Writing ICON:4, lang:0x0, size 296
Writing GROUP_ICON:ICON_OPEN, lang:0x0, size 20.
Writing ICON:5, lang:0x0, size 1384
Writing GROUP_ICON:ICON_NEW, lang:0x0, size 20.
Writing ICON:6, lang:0x0, size 296
Writing GROUP_ICON:ICON_SAVE, lang:0x0, size 20.
Writing ICON:7, lang:0x0, size 296
Writing GROUP_ICON:ICON_SAVEAS, lang:0x0, size 20.
Writing ICON:8, lang:0x0, size 1384
Writing GROUP_ICON:ICON_CUT, lang:0x0, size 20.
Writing ICON:9, lang:0x0, size 1384
Writing GROUP_ICON:ICON_COPY, lang:0x0, size 20.
Writing ICON:10, lang:0x0, size 1384
Writing GROUP_ICON:ICON_PASTE, lang:0x0, size 20.
Writing BITMAP:BMP_BACKGROUND, lang:0x0, size 6504.
Writing DIALOG:DIALOGABOUT, lang:0x0, size 198.
Writing DIALOG:DIALOG1, lang:0x0, size 406.
Writing MENU:MENU_APP, lang:0x0, size 184.
Writing STRING:4, lang:0x0, size 114
Writing STRING:63, lang:0x0, size 94

Make finished.
Total compile time 1482 ms[/color]


The RED part is the extra bagage that comes along with every operation (Link/Assemble/Build All/Run etc).

Regards,
:NaN:
Posted on 2004-06-13 13:33:13 by NaN
Hi NaN

This looks exactly like the debug build problem (project option debug) prior to 2.0.4.3
Are your observations regarding RadASM versions correct, or is this a new bug in 2.0.4.3?

KetilO
Posted on 2004-06-14 02:25:14 by KetilO
Yes, we are definitely using 2.0.4.2. Should i move onto 2.0.4.3 to fix this?

:NaN:
Posted on 2004-06-14 11:46:18 by NaN
You can always dl the bug fix for 2.0.4.2 (where this bug was fixed), if you don't wan't to use 2.0.4.3:
http://www.asmcommunity.net/board/index.php?topic=17984 :)
Posted on 2004-06-14 12:14:08 by Petroizki
The thread doesnt seem to have a link....

Regards,
:NaN:
Posted on 2004-06-19 13:36:59 by NaN