Anyone know the steps needed to resize the partition? I tried modifying partition table in boot record and Fdisk showed change but When I went to info in Fdisk it showed no change. Do you have to resize the clusters or something?
I just got a used laptop and total disk space was allocated to 98. I want to keep it but I also want to load XP-Pro to another partition.
Posted on 2004-07-05 19:53:19 by mrgone
It involves a little more than adjusting the partition table. You'll need a program like Partition Magic to do the actual resizing on the disk itself.
Posted on 2004-07-05 21:54:44 by SpooK
Thanks Spook for reply. I just spent a small fortune on software so looking for a cheap method. I'm gonna try this one:

http://www.rocketdownload.com/details/Misc/5298.htm

but with great caution. I'm gonna monitor what it does on a 7 Meg unpatitioned space at the end of my drive first.
Posted on 2004-07-06 12:33:52 by mrgone
I was using partition magic 7 and as i remember i downloaded it for free
Posted on 2004-07-06 14:53:48 by AceEmbler
Partition Magic runs about $60.00.
Posted on 2004-07-06 16:32:49 by donkey
Here's an open source alternative, comes with most Linux distros :)
Posted on 2004-07-06 17:37:13 by QvasiModo
It worked just fine! :alright:
Posted on 2004-07-06 21:42:52 by mrgone
Do you have any like that for NTFS? I had to take that Think pad back. I got an HP Pavilian now. Still want to partition it now for 98. That Think pad had non standard idiocingcracies I could not deal with. Did you ever notice that API "file mapping" does not work at all? My brother works in wireless internet and said IBM did not support the wireless cards untill drastic over haul of differences between standard system and IBM. Apparently the hardware is incapadable with standard off the shelf components. It was a virtual nightmare trying to load NT on that machine. Anyway I got HP now and everything works but I need 98 on it too because I want to attempt some WDM's. I finally got Walter Oney's book and DDK suite #3. And I plan to use Windbg properly (you know with two computers) the laptop being one. Got a huge project ahead of me but at the rate they are paying I can afford to take my time right now...lol.
Posted on 2004-07-16 15:10:17 by mrgone
Weird, I have always bought Thinkpad and have never experienced any of those problems. I have an off the shelf wireless router, no problems with it, I have wireless (11a), no problem. I have a cellular modem and 98SE & 2K both on one thinkpad and have never experienced any OS problems related to the TP. I currently have 2 thinkpads, a 2647A2U (T20 for programming) and a 2379DKU (T42 for business).
Posted on 2004-07-16 15:46:53 by donkey
What I was saying that originally they didn't work because of hardware differences. Check this out Donkey , I'm curious. Run Icz' tut #13. I could not get that file mapping function to work. It might work on yours. There were other API issues that maybe I could have handled differently but the HP works just like a standard desk top throw together.
Posted on 2004-07-17 11:44:25 by mrgone

Did you ever notice that API "file mapping" does not work at all?

If that was the case, you wouldn't be able to execute any programs...
Posted on 2004-07-17 11:53:38 by f0dder
As f0dder says if there was a problem with the FileMapping API then nothing at all would run as it would not even be able to start Windows. The FileMapping system is central to Windows and is used throughout it. I would suggest that the problem you were having has nothing at all to do with IBM Thinkpads. I have never encountered any compatibility problems and have owned a Thinkpad since the 1980's when they were monochrome only, and have had every major version of the Thinkpad T series at one time or another as well as the X series before that.
Posted on 2004-07-17 12:11:28 by donkey
Just run Icz tut#13 on your think pad and see if it works. That allows a user mode program to pull in the disk image of a file.
Posted on 2004-07-19 13:41:08 by mrgone
Just plain old filemapping, mrgone - does nothing you couldn't do with readfile/writefile, doesn't give you any special privileges or anything...
Posted on 2004-07-19 14:07:32 by f0dder

Just run Icz tut#13 on your think pad and see if it works. That allows a user mode program to pull in the disk image of a file.


I have no need to look at Iczelion to know for a fact that file mapping works perfectly on all IBM thinkpads, my system and files libs both use it extensively. The tutorial does absolutely nothing, as is evidenced in it's source code, I hope you were not expecting that the file would be loaded into the edit control ?

.if ax==IDM_OPEN

mov ofn.Flags, OFN_FILEMUSTEXIST or
OFN_PATHMUSTEXIST or OFN_LONGNAMES or
OFN_EXPLORER or OFN_HIDEREADONLY
invoke GetOpenFileName, ADDR ofn
.if eax==TRUE
invoke CreateFile,ADDR buffer,
GENERIC_READ ,
0,
NULL,OPEN_EXISTING,FILE_ATTRIBUTE_ARCHIVE,
NULL
mov hFileRead,eax
invoke CreateFileMapping,hFileRead,NULL,PAGE_READONLY,
0,0,NULL
mov hMapFile,eax
mov eax,OFFSET buffer
movzx edx,ofn.nFileOffset
add eax,edx
invoke SetWindowText,hWnd,eax
invoke EnableMenuItem,hMenu,IDM_OPEN,MF_GRAYED
invoke EnableMenuItem,hMenu,IDM_SAVE,MF_ENABLED
.endif
.elseif ax==IDM_SAVE

Obviously it does not read any of the file into the edit control at all, it seems to only map it and that's it. This is definitely completely unrelated to IBM Thinkpads as it reacts identically on both my Thinkpads and also on my test box.
Posted on 2004-07-19 16:59:47 by donkey
donkey, try "save" from the file menu after you open the file :) - and no, indeed it doesn't load into the edit control.
Posted on 2004-07-19 17:04:00 by f0dder
Hi f0dder,

Ofcourse I tried that and it worked as expected on both Thinkpads, I just thought maybe he was expecting it to open the file in the EDIT control. Also I searched IBM's service database and could not find any file mapping related problems listed. Anyway it's not like I haven't used filemapping extensively, and have done so since the old B&W Thinkpads.

mrgone,

What was the model of IBM Thinkpad so I can check the service database to find out what the problem was.
Posted on 2004-07-19 17:16:54 by donkey
I've never seen that happen on anything but a Thinkpad. I was told it was because IBM has their own windows. Try partitioning it and loading say Window 2000 and see how long it takes to get BSOD,s.
Posted on 2004-07-20 20:42:53 by mrgone

I've never seen that happen on anything but a Thinkpad. I was told it was because IBM has their own windows. Try partitioning it and loading say Window 2000 and see how long it takes to get BSOD,s.


See what ????

The program worked exactly as it was written. There is no code in the tuutorial that will display the file, thats it. No computer by any manufacturer will display it. It saves the file as expected on my thinkpads. IBM ships Microsoft Windows or Linux with their computers, they include IBM drivers on the CD in a separate folder and the only files that they add to Windows are the OEMINFO.INI file and the LOGO.SYS splash screen, that every manufacturer adds to Windows. Like every other manufacturer IBM is limited to what it can do by the Microsoft OEM license agreement so no, they are not shipping their "own" Windows.

Do you have a model number of Thinkpad or even a series letter ? I have searched the web and still find no problems that anyone has reported that even come close to this.
Posted on 2004-07-21 06:23:20 by donkey
I just traded it in for HP. Didn't like performance. Sorry hope I didn't offend you Donkey. Just wanted to report my findings.
Posted on 2004-07-21 22:15:41 by mrgone