I have been trying to recompile the source from this tutorial under the following conditions:
masm32 v8 (latest)
WinAsm Studio (build 21) close to latest :-P
Windows 2000 SP3

The source compiles without error but when run, flashes the window.s for a brief moment and exits. The original included binary works ok. I'm making no changes to the source other than trying a few debugging windows to see whats up

I've been trying to locate an un-preserved ebx, ebp, or edi but I'm really getting nowhere. Can someone point me in the right direction to getting this beast to re-assemble and run?
Posted on 2004-07-16 11:50:06 by Cprompt
Could you attach a zip file with the original executable and the one you have built?
Posted on 2004-07-16 12:06:39 by f0dder
Sure thing. Zip file should be attached here. I did not include the word.txt file though.

Thanks for having a look!
Posted on 2004-07-16 12:26:04 by Cprompt
Hrm, I've compared the IDA disassembly results with windiff, and it appears that code and data are the same in both versions, but that imports and resource data is different. Furthermore, it seems that there's a crash occuring in the wndproc handler before calling ShowWindow, some time after the ShowWindow call, and that the crash is because of a stack problem (BUT! I just get the closing window, not a GPF errorbox).

Hrm - I'll look a bit more at this.
Posted on 2004-07-16 13:51:04 by f0dder
OK. You are getting the same result as me. :-)

I appreciate you looking at it and would be most interested in your findings.
Posted on 2004-07-16 14:09:06 by Cprompt
Okay, solved - it is indeed a stack problem. I looked at the makefile, and added "/stack:2000000,2000000" to the linker commandline, and now it works perfectly :)
Posted on 2004-07-16 14:17:58 by f0dder
Damn it. Should have seen that.

Thanks so much for your efforts!
Posted on 2004-07-16 22:10:52 by Cprompt
The simplest errors can lead to hard to find bugs, as you're looking for everything but the simple :) - heck, I did disassembly, saved the listings, did windiff, and looked at the results - before I checked the makefile.
:stupid:
Posted on 2004-07-16 22:30:55 by f0dder
Today I dowloaded this tut, and U have the same problem. The window flashes and that'all.

Il the make file there is the "/stack:2000000,2000000" and that does not resolve my problem.

What is the solution ?

Thanks
Posted on 2005-09-12 14:51:33 by Grincheux
i just made this: got tut->convert to winasm project->build->run->flashing->add "/STACK:2000000,2000000" to the linker commandline->build again->run->ok :)

post here your commandlines or wap/rap or other what you have so we can see what is wrong. regards!
Posted on 2005-09-13 02:31:21 by Shoo