Hi I have WinXP with no SP installed. I recently purchased a wireless router with a wireless card (WMP11). I had my Sis 900 integrated NIC enabled at all times, and to test my WMP11 I installed it in my main machine (meant for the machine in my room). It worked so I then removed it and uninstalled the driver and software and ever since Windows XP has been acting weird with my SiS 900 NIC. First of all for some reason, it wont get an IP, WindowsXP always resorts to the autoconfig thing. I have determined that it isnt my router because I'm in Mandrake Linux 10 right now on the exact same machine!!
secondly when I try to renew the IP it gives me the following error message:

"An error occured while renewing interface Local Area Connection 2: An operation was attempted on something that is not a socket."


I am not sure what is happening, I need this fixed as soon as possible as it is quite an inconvenience to switch to Linux whenever I need the net ( I sometimes need to get certain constants for my 1st yr Physics lab reports)
Posted on 2004-10-27 19:12:08 by x86asm
I fixed it now lol, this tool did it for me, it is called WinsockXPfix, I ran it rebooted my PC and all my headaches went away :)
Posted on 2004-10-27 19:54:33 by x86asm