Hello, i brought AOA a long time ago, finally go around to reading spent a while downloading and installing masm32, hla, then radasm

when i do the helloworld code in radasm and compile i get a popup saying "Error during process creation nmake build"

i try to compile with the cmd prompt ( i am on windows xp btw)

"C:\hla C:\hla\projects\hello\hello.hla
Assembling: C:\hla\projects\hello\hello.asm
MASM : fatal error A1000: cannot open file : C:\hla\projects\hello\hello.asm
Error returned by Assembler = 1"


any help would rock as i am rather excited about this language and wanna start to program it asap, and not being able to compile, proposes a nice lil problem hehe.


Damnation
Posted on 2004-12-13 17:13:52 by Damnation
The first error probably means that you don't have nmake, or you don't have a makefile written.

second error I can't help you with. Try a verbose compile and list the results here.

RadAsm takes some configuration. There is a help file at the RadAsm site.

http://radasm.visualassembler.com/


I'm also working on an alternative HLA-specific IDE called HIDE that requires no setup and auto-builds makefiles. All the files needed to assemble programs from simple to advanced are included. It's less sophisticated than RadAsm but quicker to setup.

http://www.geocities.com/kahlinor/HIDE.html
Posted on 2004-12-13 20:03:36 by Kain
Thanx for your reply, i shall take alook at that help file, and get your "Hide" when at college, seeing as they have a 10mb line, i'll dl there cause poor lil old me stuck on 56k at the mo : 'o( but once again thankyou for your fast reply. i shall post back if i continue to find problems : o)
Posted on 2004-12-14 03:44:56 by Damnation