Hi all

Help me test RadASM 2.1.0.6

Important!
You must previously have installed 2.1.0.5


2.1.0.6
- Improved build processing (optional).
- Progress indicator.
- Build process can be terminated with Esc.
- Support for FUNC and $invoke macros.
- Code complete.
- Parameter tooltip.
- masm.ini section [Api] Trig=invoke,func(,call,$invoke(
- Fixed bug with Resource, Accelerator and String table.
- Improved property fake combobox.
- Acts more like a real combo.

Get it here:
http://radasm.visualassembler.com/Upload/RadASM2106.zip

KetilO
Posted on 2004-12-18 08:34:01 by KetilO
Hi all

New upload.

- Fixed bug with Run w/debug
- Improved font options.

KetilO
Posted on 2004-12-19 14:37:19 by KetilO
KetilO,

cool stuff!,
just a quick though, is the new progress bar on the output window making any kind of a delay?
seems my build has become slower (?)..
Posted on 2004-12-19 15:27:31 by wizzra
Hi wizzra

Complete build of RadASM on 500Mhz PIII, Win98

RadASM 2.1.0.5
Make finished.
Total compile time 12720 ms

RadASM 2.1.0.6
Make finished.
Total compile time 12771 ms

I doubt you are able to notice.

KetilO
Posted on 2004-12-19 16:21:20 by KetilO
hehe true :)
though, it still a delay ;)
Posted on 2004-12-20 01:33:48 by wizzra
Hi;
I dunno this is a bug or appeared only for me.

OS:WinXP SP2 Turkish
Radasm working from C:\RadAsm
I checked on few PC with same OS.

Open any project then go to

Project->Project Options

Change

Debug<->Release (one to other type isnt matter)

Radasm will reopen project as you know. Now check Make menu. There is nothing in this menu. But it will fixed when you have closed and reopened Radasm.

I didnt check older versions. Maybe they have this bug too.

Best Regards
Posted on 2004-12-20 02:37:46 by RvaZero
Hi;


OS:WinXP SP2 Turkish
Radasm working from C:\RadAsm

Another problem. When i want to change Line Number Font. It shows a
'Font not found. Install new font from control panel'(something like this. Message is turkish :wink:) system message and dont permit me to change font to another one. I guess default font isnt installed on my system but at least it can show me font dialog to select another one. Isnt it?

Uhm and Ketilo can u add an option for adding RadAsm file types to shell?

I know this is simple task to add them to shell manually but this can be handy inside RadAsm.

Best Regards.
Posted on 2004-12-20 04:11:45 by RvaZero
Thanks RvaZero

I am working on it and will make an upload later.

KetilO
Posted on 2004-12-20 04:45:32 by KetilO
Hi all

New upload.

- Fixed problem with choosing line numbers font.
- Fixed problem with lost make menu.

KetilO
Posted on 2004-12-20 06:25:41 by KetilO
1. Font Option OK button not working.

2. Project Options Dialog messing up on my 19" monitor
because my font setting is Big Size (120 DPI). Resolution is 1600x1200.
Project Options Dialog is sizeable on X axis as you know but not helping.

Everything is OK at Normal Size (96 DPI) Font settings.
Posted on 2004-12-20 09:43:14 by RvaZero
Thanks again RvaZero

New upload

1. Fixed
2. Fixed

KetilO
Posted on 2004-12-20 13:48:22 by KetilO
Hi all

New upload.

- Many improvments on code properties listbox.
- Updated MakeDef addin.

KetilO
Posted on 2004-12-21 07:27:49 by KetilO
Hi all

New upload:

- Fixed bug where some dialog options did not enable apply button.
- Fixed a 'spaces in filenames' problem on Run and Run w/Debug build commands.

KetilO
Posted on 2004-12-21 15:24:11 by KetilO
Hi;

I dunno Radasm's compability with higher resolutions and big size fonts. But on big size fonts resource editor(texts at properties) and info tool behaves weird. Strings not shown fully or cropped.

On normal fonts everything is fine.
Posted on 2004-12-23 02:52:29 by RvaZero
Hi RvaZero

I will have a look at it.

KetilO
Posted on 2004-12-23 06:03:32 by KetilO
Hi all

New upload.

o Added option to set default dialog editor font.
o Added support for local code properties.
- masm.ini section {Code] Local={C},local $
- Show the code complete listbox with only proc parameters and locals using Shift+Ctrl+Space
o Added FONT resource type.

KetilO
Posted on 2004-12-23 06:05:26 by KetilO
NT WS 4.0 sp 6
1. Local and proc vars don't appear in list box (with ctrl - shft - space the list box doesn't appear at all)
2. GPFs happen while compiling. From what I can see in Soft Ice - the GPFs occure in system dlls space using pointer- that means - some where in your code space your are changing esi and you don't restore it to the systen value before returning control to the system.
Posted on 2004-12-23 06:44:04 by The Svin
Hi The Svin

1.
a) Did you update masm.ini as mentioned in ReadMe.txt?
b) The caret must be in a proc with parameters and/or locals
2.
Could not find any register preservation problems. Could you give me some more info?

KetilO
Posted on 2004-12-23 09:19:47 by KetilO
1. Yes I did if you mean:
Local={C},local $
in "code" section
2. It's hard to say something in addition, may be just in other words

When I start building (ctrl F5) shortly after "progress bars" appear - SoftIce shows up reporting of "access violation", it happens more then one time (2 or 3). Pointers in machine instructions where the violation occurs are all .

That's why I suggested that might be it is because of esi isn't preserved.
It's just a guess, it might have happend 'cause of some other data send to sys. dll funcs was wrong. For example it might have been some pointers you passed to API and then the API func. might have loaded it into esi and only then on that stage GPF occurs. It's hard to say 'cause to figure out I need back trace to the caller.
Posted on 2004-12-23 13:27:42 by The Svin
Hi The Svin

1.
Can this be a russian keyboard problem or a NT problem?


My_Proc proc My_Param:DWORD
LOCAL My_Local:DWORD

mov eax, <--Pressing Shift+Ctrl+Space here should show list with My_Local and My_Param

2.
Threaded build is now optional. Option / Code Editor Options / (Files) Threaded build

KetilO
Posted on 2004-12-24 04:41:55 by KetilO