Hi KetilO,

when I try to choose a path for my OllyDbg and a directory name contains a space
character then OllyDbg will not start (could not be found!).
e.g. 'c:\Directory Path\OllyDbg' will not work!

It could be avoided when I manualy change the path to 'c:\Direct~1\OllyDbg'
(I haven't tested with the other path names but maybe the same...)

I thought I let you know...

Best regards and thanks for your tool
BoostMan
Posted on 2005-04-11 05:25:40 by BoostMan
Hi

A better way is to update ini files, templates and your projects with quotes.

For ini files (all project types):
7=0,0,"$E\OllyDbg",$.exe
17=0,0,"$E\OllyDbg",$.exe

For projects:
Run w/Debug: 0,0,"$E\OllyDbg",5

KetilO
Posted on 2005-04-11 06:45:26 by KetilO
Hi,
thanks for your answer, but:

all my 7=.. & 17=... in my masm.ini are with quotes (clean RadASM
install - nothing changed in the ini...)

RadASM don't like it when under a directory name contains a space
($E=C:\Directory Path\OllyDbg).  Even when I put the path in quotes.
RadASM starts OllyDbg only when I cut the directory name after 6 character
followed by ~1 (old 8 char name-convention?!) ($E=C:\Directo~1\OllyDbg)

This is of course no real problem and maybe not so many people got directories
with spaces. But I thought RadASM should take all path names - even when
there's an automatical selection menu for it.

I hope the problem (not a real one ;-) ) is now clearer..

Regards,
BoostMan
Posted on 2005-04-11 07:25:16 by BoostMan
You still have to check your Project / Projectt Option / Run w/debug setting
for the project you are trying to debug.

KetilO
Posted on 2005-04-11 08:09:24 by KetilO
:D Thanks again for your quick support and your time!!!!

It is working now with spaces in directory names...

Take care, BoostMan
Posted on 2005-04-11 08:45:56 by BoostMan