I get this everytime I try to compile my current project:
Error: Unexpected characters.
Display:
Instruction:
Source:
kernel32.inc [25]
struct.inc [60]
struct.inc [69]


Here's the source of my kernel32.inc file.. it's just the normal standard include file that comes with FASM (which is why I'm so confused as to why it's giving an error all of a sudden

;line 1
; KERNEL32.DLL structures and constants      line 2

struct SYSTEM_INFO
  wProcessorArchitecture      dw ?
  wReserved                  dw ?
  dwPageSize                  dd ?
  lpMinimumApplicationAddress dd ?
  lpMaximumApplicationAddress dd ?
  dwActiveProcessorMask      dd ?
  dwNumberOfProcessors        dd ?
  dwProcessorType            dd ?
  dwAllocationGranularity    dd ?
  wProcessorLevel            dw ?
  wProcessorRevision          dw ?
ends

struct OSVERSIONINFO
  dwOSVersionInfoSize dd ?
  dwMajorVersion      dd ?
  dwMinorVersion      dd ?
  dwBuildNumber      dd ?
  dwPlatformId        dd ?
  szCSDVersion        db 128 dup (?)
ends  ;line 25



Where is this coming from? I've even tried reming out the db 128 dup (?)  line, thinking it didn't like that. Doing that didn't fix it, I still go the error.. I even opened the file (since it's a text file more or less) in a hex editor to make sure there weren't any crazy non-printable hex codes in the whitespace, and there wasn't.. Just standard od/oa (lf/cr) stuff and the normal alphanumber text stuff.. Kinda puzzled..
Posted on 2005-09-27 22:34:09 by EtErNiTy
If I remember correctly


struct OSVERSIONINFO
  dwOSVersionInfoSize dd ?
  dwMajorVersion      dd ?
  dwMinorVersion      dd ?
  dwBuildNumber      dd ?
  dwPlatformId        dd ?
  szCSDVersion        rb 128
ends


I thought fasm comes with their own includes? Why don't you just use them?
Posted on 2005-09-27 22:47:53 by roticv
I thought I was.. It says the issue is in kernel32.inc... when I right click the tab at the bottom of the screen and click open folder it drops me into the equates folder of fasm  I'm using FASM 1.64 which version are you running? I recently downloaded it so I might be running a newer version which means I might be working with newer include files

EDIT: Just to test if that line was the cause, I changed the dup line and I still get the same error on the same line.. I think it might be something in my project's asm file though, because I load up the examples that coe with fasm that also include the win32a.inc file and they compile and run just fine... But I'm puzzled as to what in my source file could possible cause the error in kernel32.inc, what puzzles me specifically, is the error drops me at the end of the 2nd struct almost implying that the problem is inside that very file (kernel32.inc) and even more specifically, that very struct block.. But it doesn't appear to be so when I compile the examples that indirectly (they include win32a.inc which includes kernel32.inc) include that file..
Posted on 2005-09-27 22:52:00 by EtErNiTy
you should firstly check your code - sometimes compiler (not only fasm) does not say correctly where is error: simpliest example: you can define something, then include some inc and get error there is something redefined etc. - this sit-s are more hard and full source need to be checked. btw i got your zip from another topic and will look in it little later - when i'll have some time. regards!
Posted on 2005-09-28 01:43:50 by Shoo
I'm really sorry. The version that I was using is 1.56. Looks like fasm has advanced quite well while I was not doing much fasm coding.  ;)
Posted on 2005-09-28 01:55:32 by roticv
You need to post the code you are trying to compile.
Posted on 2005-09-28 04:00:52 by GorillaCoder
No prob Roticv :)

Thanks -very- much for looking at it Shoo! :)  And yeah that's definately been my experience so far, which is why i'm leaning towards it much be something in my code.. I did convert over the entire windows.inc file from MASM and am using that because it's much much more thorough then the win32 stuff that comes with fasm, I did rem out the windows.inc file though just to make sure it wasn't that, unfortunately I still got the error.. It's -gotta- be something in my code though because the examples compile fine.. hmm..

GorillaCoder, I have class today but have two long breaks throughout my day, I'm gonna see if I can fix that particular error during them, I'm a little reluctant to posting it because I just posted y source in MASM format in another thread, I don't wanna swamp and burden it with zip after zip.. if I can't fix it, I'll see what I can do about making up a zip and attaching it
Posted on 2005-09-28 07:14:49 by EtErNiTy
Make sure you don't have a problem of mixing one version of fasm with another version of include files - a lot of things have happened in the recent FASM releases.
Posted on 2005-09-28 09:38:25 by f0dder
Thats a good point, I'll check that.. They should be the same version because I think I downloaded them both recently, but I'll check it anyhow
Posted on 2005-09-28 21:36:26 by EtErNiTy