\Masm32\Bin\ML /c /coff /Cp /nologo /I"\Masm32\Include" "C:\Documents and Settings\Owner\Desktop\Image3.asm"

Assembling: C:\Documents and Settings\Owner\Desktop\Image3.asm

\Masm32\Bin\Link @"C:\WinAsm\link.war"

Microsoft (R) Incremental Linker Version 5.12.8078
Copyright (C) Microsoft Corp 1992-1998. All rights reserved.

/SUBSYSTEM:WINDOWS /RELEASE /VERSION:4.0 "/LIBPATH:\Masm32\Lib" "C:\Documents and Settings\Owner\Desktop\Image3.obj" "/OUT:C:\Documents and Settings\Owner\Desktop\Image3.exe"
LINK : fatal error LNK1104: cannot open file "C:\Documents.lib"

What the hell is Documents.LIB
Posted on 2005-11-12 22:12:19 by shism2
Not sure, but having a double quotation before the switch doesn't look right.


/SUBSYSTEM:WINDOWS /RELEASE /VERSION:4.0 /LIBPATH:"\Masm32\Lib" "C:\Documents and Settings\Owner\Desktop\Image3.obj" /OUT:"C:\Documents and Settings\Owner\Desktop\Image3.exe"


As said, not sure. Hope it helps though. :)
Posted on 2005-11-12 22:21:40 by Seb
Hm I think thats for the other commandline..
Posted on 2005-11-12 22:35:14 by shism2
Just a guess but try moving image3.asm to a folder with no spaces in its path.  I seem to remember having similar problem...

best regards,

czDrillard
Posted on 2005-11-13 10:12:14 by czDrillard


\Masm32\Bin\ML /c /coff /Cp /nologo /I"\Masm32\Include" "C:\Documents and Settings\Owner\Desktop\Image3.asm"

Assembling: C:\Documents and Settings\Owner\Desktop\Image3.asm

\Masm32\Bin\Link @"C:\WinAsm\link.war"

Microsoft (R) Incremental Linker Version 5.12.8078
Copyright (C) Microsoft Corp 1992-1998. All rights reserved.

/SUBSYSTEM:WINDOWS /RELEASE /VERSION:4.0 "/LIBPATH:\Masm32\Lib" "C:\Documents and Settings\Owner\Desktop\Image3.obj" "/OUT:C:\Documents and Settings\Owner\Desktop\Image3.exe"
LINK : fatal error LNK1104: cannot open file "C:\Documents.lib"

What the hell is Documents.LIB


Try,


link /SUBSYSTEM:WINDOWS /RELEASE /VERSION:4.0 /LIBPATH:\Masm32\Lib /OUT:"C:\Documents and Settings\Owner\Desktop\Image3.exe" "C:\Documents and Settings\Owner\Desktop\Image3.obj"


The quote before each of the switches means that the switch and string are passed as normal, instead you are wanting to quote the path for the application to detect it, even with the spaces. I'm almost certain this will work.

Regards,
Bryant Keller

EDIT: Sorry, forgot a double quote ;)
Posted on 2005-11-14 09:33:25 by Synfire
Why does masm do this when I compile though???? Will I have to configure it like this everytime?
Posted on 2005-11-14 14:04:21 by shism2
It's not happening to me... which WinAsm version are you using? Could you post your project file?

Also consider posting at the WinAsm forum instead:
http://www.winasm.net/
Posted on 2005-11-14 15:38:47 by QvasiModo