The new pre-release (the first serious one) of Assembler Workplace (the programmer's editor for fasm) is available in the "tools" section of flat assembler zone ( ).
The current version assumes that fasmw.exe is in your PATH, I will allow compiler path setting in the next release.

I'm also going to enchance AsmWork with two additional sub-projects, RsEdit and AsmHelp. It will take some time (probably long) to finish them, so if you think you'd need these tools, please consider joining me in coding - if you help, these tools will be finished earlier. The RsEdit will be visual editor of binary resources, AsmWork will automatically attach your RsEdit-created resources to your executables (there will be also option to remove '.reloc' at the same time). The AsmHelp will be simple module running when the F1 key is hit in editor - it will get the word at caret and search for this topic (instruction, fasm directive or API symbol) in help files.

The whole project (but without help files package) should fit on the one floppy.

Please let me know, if you are interested.
Posted on 2001-12-16 14:00:39 by Tomasz Grysztar
I tried it, and I think it's great. Of course, it's still incomplete, but usable, very small and best of all for me, everything fits on a floppy including the compiler.

The feature I was waiting for a couple of weeks is finally there: the use of the command line to get an asm file. I tried to put this function on my own before and it worked, but I had a memory leak. One thing though, perhaps I could help a little, is that it would be good if we could send more than one file on the command line.

Also, one thing that would be good would be the ability to customize the menu with an .ini file, kinda like the qeditor from Hutch.

Continue the good work, I'm becoming more and more a fasm user every week.
Posted on 2001-12-18 11:50:41 by Silas
There already is feature to specify more than one file in the command line. And drag'n'drop, too.
Posted on 2001-12-18 12:38:40 by Tomasz Grysztar
Although I'm not a fasm user I wanted to let you know that the mouse wheel is not working. I think you need to handle the WM_MOUSEWHEEL message.

P.S. Good job that custom edit control!:alright:
Posted on 2001-12-18 13:16:28 by Thomas