I have created a Server socket, first i initialized the winsock with WSAStartup, then i used bind, and then listen and accept. everything goes when i check for errors. i have also created a thread which is supposed to receive the incomming data, but i always get the WSAENOTCONN error while trying to read the data.
can anybody help me ?

P.S : The server is on the blocking mode and im using Winsock 1.1
Posted on 2006-04-01 00:02:02 by XCHG
You need to connect your socket.
Posted on 2006-04-01 01:29:42 by roticv
Connect the server socket ? i thought binding and listening was all i had to do to establish the server. can anyone give me a complete working example of a server socket made with winsock ? 
Posted on 2006-04-01 03:36:21 by XCHG
Why haven't yuo looked at the Networking FAQ ? There is a link to MadWizard's site there. Read the networking tutorial.
Posted on 2006-04-01 04:18:47 by ti_mo_n
...And then there's the classic, http://beej.us/guide/bgnet/ . It's pretty straightforward, and although it's UNIX/C centered, it's easy enough to adopt for both assembly and windows.
Posted on 2006-04-01 04:20:25 by f0dder

Why haven't yuo looked at the Networking FAQ ? There is a link to MadWizard's site there. Read the networking tutorial.


I think because the FAQ section is quite messy and rather vague. I intend to resolve the FAQ issue once we get a working site to compliment this forum software.
Posted on 2006-04-01 04:34:20 by SpooK
The FAQ is a bit of a hodgepodge, yes - it needs to be more or less redone. It would be pretty nice if somebody with decent english skills and an enormous amount of free time would "distill" the various posts in threads into a more FAQ-like writeup - including, of course, the URL to the original thread.
Posted on 2006-04-01 05:01:05 by f0dder

The FAQ is a bit of a hodgepodge, yes - it needs to be more or less redone. It would be pretty nice if somebody with decent english skills and an enormous amount of free time would "distill" the various posts in threads into a more FAQ-like writeup - including, of course, the URL to the original thread.


Note that this is a job for moderators, as the FAQ section is locked down to the general public (too many posts going astray there).
Posted on 2006-04-01 06:28:39 by SpooK
Shoot, i was trying to send the data through the bound socket, i didnt know about the return value of the recv() which is the connected socket. bummer.

thank you guys, i appreciate it and thanks for the links.
Posted on 2006-04-02 01:19:39 by XCHG