Ok so i never tried fasm before and thought i would give it a try downloaded the newest version from their website

I extracted the files to a directory opened the fasmw.exe editor
opened the example program HELLO.asm then clicked the run button
and i get and error Error: File not included

i did some experiments and it seems it does not want to include anything at all when ever i try to include any kind of file i get the same error, This seems like the new tool of choice for me so i would like to see it work please help

Running Windows XP Pro Service Pack 2
fasmw.exe 1.67.7
Posted on 2006-08-02 19:45:01 by ChaosVisum
Hrm, I downloaded fasm and tried Hello.asm in the FasmW editor and after I hit compile I got the same error. It points to line 4 in Hello.asm meaning the included file win32ax.inc located one directory up in include is missing.

I don't know how to set the include environment variable with fasm but I was able to hardcode (brrr) the path to win32ax.inc and compile like that.
Posted on 2006-08-02 19:55:28 by JimmyClif
Just add the full path to \FASM\INCLUDE folder into the INCLUDE environment variable.
Posted on 2006-08-02 20:01:53 by arafel
LOL, Chapter 1 Page 6 in the Fasm.pdf manual.


For example, when you have unpacked the flat assembler files into the c:\fasmw directory, you should put the following two lines into your c:\fasmw\fasmw.ini file:

Include = c:\fasmw\include

Posted on 2006-08-02 20:11:40 by JimmyClif
ChaosVisum,

Look here:

http://board.flatassembler.net/topic.php?t=4759

That should work for most/all examples.

hth,

farrier
Posted on 2006-08-02 20:24:58 by farrier