I have the jpg in resource with id "101".....Now the function says
Resource file entries should use the identifier ?IMAGE? for all image files to be loaded by this procedure. For backwards capability, bitmap files may have the identifier ?BITMAP?


What does this exactly mean...The image name should be IMAGE.jpg?

I m using this code but doesn't loads the jpg

	.if	eax == WM_INITDIALOG
invoke BitmapFromResource,hInstance,101
mov hBitmap,eax
invoke CreatePatternBrush,hBitmap
mov hBrush,eax

.elseif eax==WM_CTLCOLORDLG
mov eax,hBrush
ret

TIA
Posted on 2006-09-29 09:08:37 by sonic
Very strange...
It works in RadAsm but not in WinAsm

I tried to declare the image resource type as IMAGE in WinASm ..it compiled but didn't show anything

101 IMAGE DISCARDABLE "sudoku.jpg"

I tried

101 BITMAP DISCARDABLE "sudoku.jpg"

then it gave me error "bitmap file sudoku.jpg is not in 3.00 format"


An suggestions.....

Here is the working RaDAsm code.......Tell me if its OK
Attachments:
Posted on 2006-09-29 11:08:11 by sonic
threr is no res\ subfolder in your zip to simulate your situation.
if use existing res - everything is ok in winasm studio also...
Posted on 2006-10-02 00:33:11 by Shoo
i had study your project and guess that possible radasm generates that folder with includes by itself: rc script with dialog from dlg, and rc script with other resources from project settings - it is not used in winasm studio, which uses directly rc file for resources. thus it does not work. 
Posted on 2006-10-02 03:27:25 by Shoo
Thanks for having a look shoo......i was getting error in winasm saying not compatible rc if i loaded the jpg as IMAGE type but i tried to compile and it compiled happily
Posted on 2006-10-02 16:22:54 by sonic