I am running WinXPro.

When 'Set Assembler', and 'Programming Languages' is set to RadASM I get errors on all of the addins when opening RadASM v2.2.1.0. The addins are in the AddIns directory.

If I change the Assembler to HLA, RadASM opens without errors but the Assemble button is grayed out.

My Directories and Variables are listed below. I believe this is what the instructions I have managed to garner suggests. Could someone please inspect, and tell me if this is correct.
I obviously have something not set correctly but I have no idea where to look.
The problem probably lies in a .INI file but which one, and what changes would be necessary? TIA

Directories and Variables
----------------------------------------------------------------------
C:\hla

C:\masm32

Directory of C:\RadASM

[.]                  [..]                           
                                           
                                         
                                           
              AsmReadMe.txt        bcc.ini              bcet.ini
cpp.ini              fasm.ini            fb.ini              fhla.ini
GoAsm.ini            HL.dll              hla.ini              HLLReadMe.txt
html.ini            lcc.ini              masm.ini            nasm.ini
RACad.dll            RACodeComplete.dll  RadASM.exe          RadASM.ini
RadASM.ini.zip      RadFavs.ini          RAEdit.dll          RAFile.dll
RaGraph.dll          RAGrid.dll          RAHexEd.dll          RAVideo.dll
SprSht.dll          tasm.ini            WBDll.dll            WhatsNew.txt
              31 File(s)        814,595 bytes

Directory of C:\RadASM\AddIns

[.]                    [..]                 
                AddAccel.dll          AddinMana.dll
AdvEdit.dll            AlexMenu.dll          asciiTab.dll
asciiTab.emf          AsmVars.dll            AutoCorrect.dll
bcc.ct                bcet.ct                Bitmask.dll
CodeTemplates.dll      Collapse.dll          Colref.dll
cpp.ct                CppParse.dll          CreateProject.dll
CreateProto.dll        CreateProtoEx.dll      CtrlNames.dll
DialogPreview.dll      DlgToWin.dll          DragProp.dll
e-help.dll            fasm.ct                fb.ct
fb.kwl                FBAddin.dll            fhla.ct
FlipCase.dll          FontBuilder.dll        fpu.kwl
goasm.ct              GoAsm.kwl              hla.ct
hlpF4.tmp              hlpF5.tmp              html.ct
InsertColor.dll        lancome.ini            lcc.ct
luha.bmp              MakeDef.dll            masm.ct
masm.kwl              nasm.ct                NoteTools.dll
NSISScriptEditor.dll  platsdk.dll            Preview.dll
ProcDump.dll          ProjectTimer.dll      ProjectZip.dll
PthExpl++.dll          raASCII.dll            raBitMask.dll
RADbg.dll              RadFavs.dll            RadHelp.dll
RADToolBar.dll        raGColor.dll          ReallyRad.dll
RES2DLG.DLL            ResourceID.dll        SourceSafe.dll
StyleMana.dll          style-manager.dll      TabAddin.dll
tasm.ct                TbrCreate.exe          TxtLnkMan.dll
VersionControl.dll    Version-Inc.dll        winapi.kwl
WinErr.dll            WinErr.Ini            x86.kwl
              77 File(s)      1,679,182 bytes

Environment Variables > System Variables > Path =
~...;C:\hla;C:\masm32\bin;%path%;set lib=C:\masm32\lib;C:\hla\hlalib;%lib%;set include=C:\hla\include;C:\masm32\include;%include;set hlainc=C:\hla\include;set hlalib=C:\hla\hlalib\hlalib.lib;set hlatemp=C:\hla\tmp;C:\masm32\bin\nmake15.exe
----------------------------------------------------------------------
Posted on 2006-10-09 15:08:33 by neubie
Hi neubie

Everything is as it should be, except RadASM is NOT a programming language and should be removed.

When hla or other high level languages are selected the assemble button is disabled as there is no such thing in high level languages.

KetilO
Posted on 2006-10-10 03:28:09 by KetilO
Thank you. I shall remove RadASM from the Programming Languages. Obviously, I do not quite understand the setup procedure. Let's see how far I get with using the "Assembler".  :oops:
Posted on 2006-10-10 14:42:09 by neubie