Hi:
    When I clicked at the ?tools? sub menu item of OBJASM32 addin for RADASM, nothing happened. Then I took a look at the source code at line 724 on RA_OA32_AddIn.inc whose content was as below:
     
@invoke StrLCat, addr bBuffer, "\Projects\OA32Tools\OA32Tools.exe", sizeof bBuffer ? 1
 
     Therefore I understood that it tried to locate the exe file on the  ?OA32Tools? folder. But in fact there was no  ?OA32Tools? folder, so nothing happened when I  I clicked at the ?tools? sub menu item..
   As a matter of fact, OA32Tools.exe was located at  ?OA32_Tools? folder rather than ?OA32Tools? folder. (the difference was the underline)
   Therefore I renamed ?OA32_Tools?   folder to ?OA32Tools? and it worked.
   I thought other end users may encounter the same situation, so I posted it here.

P.S. In oder to make  OA32Tools full functional, the user has to manually create COMView and OLEView sub-folders in Masm32 folder, then copy the  COMView.exe and  OLEView.exe to these sub-folders respectively. Since, as far as I know, this is not explained in the documentation yet,  newbies may be confused. As for my personal opinion, it would be better to add this to the documentation.


Regards,
Guidry
Posted on 2006-11-05 19:58:46 by guidry
Will be added. Thanks!

Biterider
Posted on 2006-11-05 23:51:49 by Biterider