Whenever I try to compile the even most basic dialog I created I keep getting the following error

DlgTest.Rc(1) : error A2044: invalid character in file


I've googled and searched the forums here. Tried removing the quotes, escape the slashes etc and I'm kinda clueless now how to fix it. I mean it's a file with 1 line...I hope somebody has an answer to it.

See the attachment for more info.

Thanks for your time.

Attachments:
Posted on 2007-03-24 12:14:44 by Ixje
There must be a problem with your non-English keyboard input. Try retyping the line with making sure you're typing in English.
Posted on 2007-03-24 12:55:23 by Ultrano
I do use an English keyboard but with deadkey's enabled. Tried switching it to normal English US, but no luck. Now I recreated the project and it works.

At first I didn't want to do that because I'd rather know the solution to something like this just in case it happens when it's in a bigger project.

Anyway problem solved for the moment :)
Posted on 2007-03-25 08:13:51 by Ixje
Hummm... I'd make sure that the file always ends on a blank line (ie, the last real line has a CRLF) - and perhaps look at the file in a hex editor to see if it's saved as ANSI, or in a unicode format with BOM?
Posted on 2007-03-25 17:22:30 by f0dder
also check for bytes with value >=128. RadAsm may be awaiting UTF-8 encoding.
Posted on 2007-03-26 05:18:23 by vid