I made a program for outbound call on my old computer with win95 using TAPI 1.4.
I bought a new computer with windows Me on, put my program on it and the program work fine. I had to reinstall Win95 on my old computer and know my program doesn't work anymore. It return LINEERR_OPERATIONUNAVAIL error when calling lineOpen.

Is there some files' system missing or any other configuration require, what's missing?

Thanks,
Guy
:(
Posted on 2002-01-09 14:45:09 by Guy
Posted on 2002-01-10 02:08:40 by farrier
Anyone of you who run on Windows 95 want to try this program and tell me if it got a message error?

Just enter a phone number and press Dial.


Thanks,

Guy
Posted on 2002-01-10 12:58:12 by Guy
Guy,

after pressing Dial it comes the message below.




B7
Posted on 2002-01-12 07:20:09 by Bit7
Sorry, i've attached an italian message.

It's a page fault, probably you are doing a wrong memory addressing.

B7
Posted on 2002-01-12 07:22:29 by Bit7
Bit7,

Thank you for trying the program. It's probably missing a configuration or file(s) to make it works ok with Tapi.
It was working fine before I re-install Windows 95 on that computer.


Guy
Posted on 2002-01-12 07:47:01 by Guy
Guy,

Give us the source code and I'll try it on my
Win95 computers, if you want to share:confused:

farrier
Posted on 2002-01-12 15:02:36 by farrier
farrier,

Here's the whole program. The error is in PlaceCall routine when I call lineOpen. There maybe others ways to do it? It seem to me that the error you're getting on your computer doen't come from the same source. Remember, this program was working perfectly before I re-install Windows 95 on my computer.

Thanks,

Guy
Posted on 2002-01-12 15:49:00 by Guy