ok im being home schooled and i wanted to learn assembly anlong with finishing up my c++ knowledge so i got the art of assembly language ie hla and i got all the stuff i needed : the frozen hla complier, and masm32 for the making of the .hla files if you will now i had mvc++ 2010 express edition to start with and i tried there too.

now i made the standard hello world thing exactly as i found in the book and then i went off to cmd line note i am running win 7 hp 64 bit for laptops or so i thought...

in cmd line or cmd prompt or what ever your choice is, i went as close to the file as i could "c:\hla\projects\hw" and typed hla hw and then hla hw.hla then hla - v hw.hla adn every time i goot the same message: "  'HLA' is not recognized as an internal or external command, operable program or batch file." now what on earth happened what did i do wrong and how do i fix it? note i all ready reinstalled and re wrote it like 3-4 times. please help 2134bob
Posted on 2011-09-08 13:59:23 by 2134bob
I believe your issue is the following:

http://objectmix.com/asm-x86-asm-370/68939-having-problem-install-run-hla.html#post254066

Read also lower posts. Basically you need to add the Path of the hla compiler to your system environment variables.
Posted on 2011-09-08 16:12:53 by JimmyClif

ok im being home schooled and i wanted to learn assembly anlong with finishing up my c++ knowledge so i got the art of assembly language ie hla and i got all the stuff i needed : the frozen hla complier, and masm32 for the making of the .hla files if you will now i had mvc++ 2010 express edition to start with and i tried there too.

now i made the standard hello world thing exactly as i found in the book and then i went off to cmd line note i am running win 7 hp 64 bit for laptops or so i thought...

in cmd line or cmd prompt or what ever your choice is, i went as close to the file as i could "c:\hla\projects\hw" and typed hla hw and then hla hw.hla then hla - v hw.hla adn every time i goot the same message: "  'HLA' is not recognized as an internal or external command, operable program or batch file." now what on earth happened what did i do wrong and how do i fix it? note i all ready reinstalled and re wrote it like 3-4 times. please help 2134bob

I come from China, I don't know if you understand my words.now,I am using an online translator to answer your questions,So I hope that the simple point. :lol:
1.installation  masm32 and HLA
2.copy  \masm32\bin    ml.exe?ml.err?link.exe?mspdb50.dll  TO  \HLA\ 
3.copy  \masm32\libgdi32.lib?kernel32.lib?user32.lib    TO  \hla\hlalib\
YOU MUST NOTE NOT MOVE!!


My QQ number is 1006369837,I hope you can find me,and I hope to become a friend with you!!!
Posted on 2011-11-15 03:33:51 by feihong
Its quite possible to create MASM stuff in MSVC without using HLA :)
Posted on 2011-11-18 07:14:53 by Homer