hey guys,

i wrote a program to update resource of an exe,it worked but it corrupted the exe file,
i figured out that if nasm produced exe is used for updating resource the exe get corrupted,
and there is also an error if u compile a resource file with the nasm exe with alink,
i use another exe produced by dev c++ and its resource got updates succesfully without
corrupting the exe...

anyone know whats happening and whats to be done to resolve this issue?
Posted on 2012-09-18 10:39:44 by aloksaini
You wrote a program to update an executable's resource table which subsequently corrupted that executable but it's Nasm's fault?  :shock:

You do understand that Nasm is an assembler, not a linker, right?
Or perhaps I'm not reading your request properly...
Posted on 2012-09-18 11:07:35 by p1ranha
thanks for the reply ph1rahna..

wat im saying is i assemble an obj file with nasm then link with alink and the i updated its resource by my program which works 100% as i tested it on all executable, but with the one exe i made with nasm and alink gets corrupted everytime i update its resource...
Posted on 2012-09-18 11:12:05 by aloksaini
My guess is that your problem is with Alink not Nasm.
Try using Jeremy Gordon's GoTools http://www.godevtool.com/ and see if you experience the same issue.
My bet is you won't.  I use ( and highly recommend ) his tools myself.
Posted on 2012-09-18 19:04:56 by p1ranha
yea i also figured that out....

golink worked good but theres a problem it links in different way then alink..

all imports have to be redefined...
so i found an alternative...
and noted not to use link for future projects specially related to resources...
Posted on 2012-09-19 09:16:15 by aloksaini