I'm fairly new to MASM32, and I've run into a minor problem.

I was going through Iczelion's first few tutorials, and after a while I noticed a strange problem. In Win2k, if you run the tutorials from a DOS box in full screen mode, the system crashes completely. (No error, no warning, just boom the system restarts) I've tested this on Win98 and WinME, and it doesn't happen in either case. It's not that I really NEED it to work in this specific case, but nonetheless it seems like a bug. Any ideas on what might be wrong?

(btw it's not entirely impossible that it could be limited to just this system, it occasionally reboots just for the heck of it; the person who put the system together really didn't know what he was doing, hehe)
Posted on 2002-01-28 05:38:58 by k_oticman
I've seen at least 4 win2k boxes that 'reboots just for the heck of it', including the one i'm using at home. what i did was unplug some kind of power cable from the board (I'm sure what it was but it worked! :grin: ). hey, it's an old p2 and i'm waiting for it to give me a good reason to upgrade :grin:

as for icz's tutorials, i haven't had problems running them. so you're 'my-machine-sucks' theory may be right ;-)

Posted on 2002-01-28 07:15:09 by pixelwise
Hm, this sounds weird. Could you zip up an executable that has
this problem and post on the board? I wouldn't mind testing it.
Which version of win2k? no service packs? And, which processor?
(Athlon and a motherboard with VIA chipset, eh? ;P).
Posted on 2002-01-28 07:18:25 by f0dder
according to System properties:
Microsoft Windows 2000
Service Pack 1

the processor info:
x86 Family 6 Model 7 Stepping 3
261,620 KB RAM

if you like, I can post a zipped file, but I've checked this with quite a number of files compiled with masm32, and it's happened in all of them, including the ones that come with the distribution (like all of iczelion's tutorials, and the myriad of other examples that come with it). Well, I didn't actually check ALL of them, because I didn't want to deal with the system restarting that many times. However, I did check four or five of them.

It really only seems to happen under one specific circumstance, and that's when I'm in a DOS box, under win2k, and have put it in full screen mode. All the programs work fine, normally, and I've had no trouble (aside from my own bugs, grr..) with MASM32, otherwise. I tested the same situation on this machine (alternate boot) in Win98 and WinME. In both situations it works fine, so I dunno....hehe I only stumbled on the bug by accident, I'm just curious if it would happen on other machines with win2k, since I only have the one to test it on :)
Posted on 2002-01-28 07:32:46 by k_oticman
You say dos box... is this a command.com or a cmd.exe box? I'm
just trying to gather enough information to be able to reproduce
the problem, if that's possible. Zip up an executable and post it here.
You say it happens with the files from the distribution... but zip one
up nevertheless, who knows, you might have some evil virus :).
Posted on 2002-01-28 07:39:15 by f0dder
hehe ok :P

I was using command.com, I haven't tried with cmd.exe yet, (because I don't want to deal with the reboot). I pretty strongly suspect it's limited to this system. I don't have Win2k installed on my system at home, so unfortunately I can't easily check.
Posted on 2002-01-28 07:45:51 by k_oticman
Win2ksp2 here.
No trouble with a fullscreen cmd.exe.
No trouble witha fullscreen command.com (heh, didn't think I had
that on my box still).
Posted on 2002-01-28 07:48:50 by f0dder
hmm.... I think I'll try installing the latest service pack
maybe that'll fix it... well at least it's nice to know that this problem doesn't happen on all win2k machines, that was really my main concern :)
Posted on 2002-01-28 07:53:03 by k_oticman
I have just recently asked member to test an idea for me and the OS version that fails with the idea is Win2k sp2 so it has all of the hallmarks of another Microsoft lemon, the same program runs correctly on win95b, win98se and WinNT4 sp6a so I suspect that Micro$oft have "dunnit again" with Win2k.


Posted on 2002-01-28 12:41:24 by hutch--
i hereby proclaim myself as the stoopidest person in this board. (I'm sorry if anyone else covets the title, but I got it first :grin: )
I'm not really sure if I want to tell you this story but maybe (just maybe) it will help somebody in the future to be "less stupid" than me, so here goes:

a couple of posts up, I mentioned having 'solved' the win2k reboot problem on my machine (you know, like when I'm in the middle of working on a 10meg photoshop file and haven't saved in 20 minutes and win2k decideds to reboot all by itself without pushing my button :grin: ) . When it finally came that the pc reboots even before I can login, I decided I had to do something. What I did was unplug a thin wire from the main board, after doing which I got the same feeling I get when commenting out a line of source code (with fingers crossed). In short, I didn't even check what the wire was for!

That was 2 months ago. After I posted yesterday, I thought of opening my box to see what I really did, and maybe help my friend who's been painfully going from win2k to win98 and vice versa at least 6 times since christmas (after all, I'm the recognized 'guru' among my peers ^v* )

guess what I found out, the wire was for the cpu cooler! It means i've been running my pc for the last 2 months without its cooler (now am I stoopid or what?) And mind you, the philippines is never one of those cold places (when were lucky we get 2 full weeks of cold weather and that only in december ;-) Ask anunitu, he says he's been here.

i think the consequence of all these is that when my cpu finally decides to give up the ghost, I can't blame Intel for it :( :grin:

And no, I won't be telling this to my friends...


//btw, my previous post should have read ".. I'm not sure what it was ..." . can't edit it now.
Posted on 2002-01-29 11:53:27 by pixelwise
Erm... your PC used to boot *with* the cooler active? And *stopped*
booting when you unplugged the cooler?
:confused: :confused: :confused:
Posted on 2002-01-29 12:01:20 by f0dder
ah, no.

when it still had the cooler on, that's when i had the 'auto-reboot' problem. my theory is (now even stoopid ppl have theories, right), the cooler used to get stuck with the amount of dust build-up on it. when i opened the box this evening, i can't believe the amount of dust it's collected over the months. so, when the cooler got stucked my main board (or maybe win2k, i don't know) detects it and the pc reboots. then when i (unknowingly) unplugged the cooler, win2k got no 'stucked cooler' to detect anymore (d-uh), so it booted fine.

when i checked this evening and plugged the cooler back of course i cleaned off all of the dust, enabling the cooler to do what it's supposed to do. no more stucked cooler, so now my pc works fine (until it again gets just enough dust for the cooler to stop ;)

i hope that was clear :grin:
Posted on 2002-01-29 12:38:32 by pixelwise
No cooler = random hardboots ((temporary) processor failure).

You should get some CPU temperature monitoring software. Most
quality CPU coolers have thermometers that can be read by software.
This enables monitoring software to do a clean shutdown of your
system if it senses that temperature rises to dangerous levels
(ie, you would then get a "windows is shutting down", with possibility
to save your work, instead of hardboots).

Oh, the dust builtup in computers is amazing. Even after a week,
you should see the innards of my box :D. I usually clean it every
month or so... to avoid problems.

How old is your cooler? You might want to consider oiling it (but be
very sure to use acid-free oil then!!!), or even replace it by a better
Posted on 2002-01-29 12:48:50 by f0dder
thanks for the advice f0dder.

I do have those monitoring stuff (came with the board's installer). I'll try them this time. I'm not much of a hardware person, and usually believes that PCBs and dust are made for each other :-) I used to have a guy working for me (when i was still running my desktop publishing shop) and he was good with the oils and stuff :grin: Now I think I just have to do it myself :(

Posted on 2002-01-29 13:11:35 by pixelwise