hi all,

just a little help,

i've just installed 2K. When i compile i can't compile from my win IDE, and also i can't get the dos output to my ide window, as it was befor with w95.... think is something about cmd.exe.....

could you help me ?

thanks B7
Posted on 2002-02-01 01:29:22 by Bit7
which ide are you using? anyways the problem is that the spaces in a file location isnt being recognized. for instance if you are using qeditor you will need to make some adjustments tools/change editor settings. in there you will need to place some quotation marks around all the {B} that look like that.

"{B}"

this has also been addressed in the masm32 forum. not only does this apply to qeditor but some of the other ide's will need the same adjustment. on the other hand if you use ewanye's asmedit you wont need to change anything he has already compensated for that.
Posted on 2002-02-01 04:58:20 by smurf
Smurf, thanks,

but i didn't really understand what you mean with "{B}". Where i have to put it ? Why ?

In any case I don't know if this is the issue...
The editor i'm using is called Jens' File Editor (very useful, try it is free). It have a prompt window at the bottom, as many other ide. It worked perfect in win 95/98. Now with 2K i can't get the command output on it....

If i open a dos prompt, i can compile... But automatically from the ide pushing a button not...
Posted on 2002-02-01 07:34:22 by Bit7
i took a look at the editor but i didnt test this. in jens when you add a tool the popup window where you need to fill in the settings is where you need to make the changes. at the bottom to the right there is a drop down list of predefined parameters such as $FILE, $NAME and $PATH. more than likely you used these when you set up your assembler. you will need to place quotation marks around these such as "$NAME" this will preserve the spaces in win2k that might be in your file or even your path.
Posted on 2002-02-01 11:55:26 by smurf
well i was playing around with the parameters and i wasnt able to get it to work. it was close but the line "$PATH\ $NAME" is the problem. not only that when you exit out of jens the quotation marks wont save to the paramaters.
Posted on 2002-02-01 12:31:00 by smurf
smurf,

thanks very much for the time you're spending..

since i'm using starting directory where i've got my makefile.mak and D:\tasm50\bin is in the path, normally i never use that $file or other keywords ....
Posted on 2002-02-01 14:15:54 by Bit7
i'm going deeper...

seems a problem of the makefile:

i've checked better.... if i do "make" from dos prompt in the correct dir it don't work ! I only see the writing


MAKE Version 4.0 Copyright (c) 1987, 1996 Borland International

and then something on the makefile.mak is not well interpreted....
Posted on 2002-02-01 16:05:33 by Bit7