hi
i have a paint problem in radasm and in resedit. i dont know have clue why does it happen
i have more resource editors such as :"reshack",pexplorer and etc..
and they work ok

running windows xp . 350mhz 256 MB



maybe someone knows whats wrong in my system?

bye
eko
Posted on 2002-02-09 17:25:01 by eko
i've noticed that too. the newer version 1.09 seemed to fix that, but then again, my pixel spacing on the dialog editor is 6x6. when it was 3x3 i had a lot of problems with that.
Posted on 2002-02-09 17:29:43 by Asm_Freak
Hi eko

Try this version of RadASM and see if it helps any.

Unzip to a temp folder and read the readme file.

KetilO

1. dl before I found and corrected a bug.
Dialog properties lost it's button.
Download again.
Posted on 2002-02-09 21:07:54 by KetilO
To KetilO,

What do you think the paint problem might be.

I know ResEdit has been tested on xp, but why do
you think eko's is having a problem?

Ewayne
Posted on 2002-02-09 21:44:07 by Ewayne
Hi Ewayne

I guess the problem is that we use four windows to make the drawing rectangle. I guess others use a xor pen. I tried this but could not solve the problem by drawing behind the tooltip.

KetilO
Posted on 2002-02-09 21:49:59 by KetilO
To KetilO,

But why does it work on other xp systems?

If your not using a DC to draw on the screen
the system should automatically post a WM_PAINT
msg when an area is invalidated and needs painting.

I only use the four windows when I move or size
the control.

I use a transparent static window with a border
when I draw the dialog or a control.

Ewayne
Posted on 2002-02-09 22:07:51 by Ewayne
This is what happens when I drag the outline over the control itself.

Other than this.. it works perfect Ewayne :)
Posted on 2002-02-09 22:26:04 by Torch
To Torch,

Are you using xp?

What does it look like with a Button instead of a
Listbox?

Thanks,

Ewayne
Posted on 2002-02-09 22:43:51 by Ewayne
To Torch and eko:

See if this test ResEdit fixes your move paint
problem.

Thanks,

Ewayne

Note Sent new load program.
Sorry.
Posted on 2002-02-09 23:10:25 by Ewayne
That just crashes Ewayne. The res editor doesnt even come up hehe :). When you close it, the Send MS info about the crash box pops up.

Torch
Posted on 2002-02-09 23:31:04 by Torch
To Torch:

Sorry about that, I forgot that I'm changing the
front end of ResEdit for AsmEdit and it needs a
different load program.

Go to the above post and download it again, I
included the new load program.

Thanks,

Ewayne
Posted on 2002-02-09 23:49:26 by Ewayne
Ewayne:
now when im tring to move an item ..i cant see it move "it jumps to the place i clicks"


KetilO: still have the paint problem
Posted on 2002-02-10 08:04:12 by eko
To Torch and eko:

Try this one.

Thanks,

Ewayne
Posted on 2002-02-10 08:52:18 by Ewayne
Ewayne,

It doesnt do it on the controls anymore.. but it does this.
Posted on 2002-02-10 10:24:07 by Torch
To Torch:

I think I can fix that, but I need to know
which ResEdit you were using, the one downloaded
6 times or the one downloaded 2 times.

Thanks,

Ewayne
Posted on 2002-02-10 10:30:11 by Ewayne
The one right about my last post
Posted on 2002-02-10 11:33:01 by Torch
To Torch and eko:

Sorry to keep bugging you, but I would like to make
it right.

Try this one.

If there is still a size box paint problem on the
Work window I'll redraw or update the Work window
when moving a control.

Thanks,

Ewayne
Posted on 2002-02-10 11:43:49 by Ewayne
Still does the white bloches like it did before in my other picture.

Torch
Posted on 2002-02-10 12:16:54 by Torch
To Torch and eko:

Try this one.

It's hard to debug a problem when the program works
ok on the system you built it on.

Thanks,

Ewayne
Posted on 2002-02-10 12:46:23 by Ewayne
Ok.. that solved the white bloches on that part.. now it does this.

You should probably just do what you did on the work window :)

Sorry to cause so much trouble for you
Posted on 2002-02-10 14:35:43 by Torch